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About This Document

Related Version
The following table lists the product version related to this document.

Product Name Version

iManager U2000 V100R002C01

 

Intended Audience
This document describes how to install the U2000 and obtain the reference information required
during the installation.

This document is intended for:

l Technical support engineers
l Maintenance engineers
l Installation and commissioning engineers

Symbol Conventions
The symbols that may be found in this document are defined as follows.

Symbol Description

DANGER
Indicates a hazard with a high level of risk, which if not
avoided, will result in death or serious injury.

WARNING
Indicates a hazard with a medium or low level of risk, which
if not avoided, could result in minor or moderate injury.

CAUTION
Indicates a potentially hazardous situation, which if not
avoided, could result in equipment damage, data loss,
performance degradation, or unexpected results.
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Symbol Description

TIP Indicates a tip that may help you solve a problem or save
time.

NOTE Provides additional information to emphasize or supplement
important points of the main text.

 

Command Conventions
The command conventions that may be found in this document are defined as follows.

Convention Description

Boldface The keywords of a command line are in boldface.

Italic Command arguments are in italics.

[ ] Items (keywords or arguments) in brackets [ ] are optional.

{ x | y | ... } Optional items are grouped in braces and separated by
vertical bars. One item is selected.

[ x | y | ... ] Optional items are grouped in brackets and separated by
vertical bars. One item is selected or no item is selected.

{ x | y | ... }* Optional items are grouped in braces and separated by
vertical bars. A minimum of one item or a maximum of all
items can be selected.

[ x | y | ... ]* Optional items are grouped in brackets and separated by
vertical bars. Several items or no item can be selected.

 

GUI Conventions
The GUI conventions that may be found in this document are defined as follows.

Convention Description

Boldface Buttons, menus, parameters, tabs, window, and dialog titles
are in boldface. For example, click OK.

> Multi-level menus are in boldface and separated by the ">"
signs. For example, choose File > Create > Folder.
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Change History
Updates between document issues are cumulative. Therefore, the latest document issue contains
all updates made in previous issues.

Changes in Issue 05 (2010-11-19)
The fifth commercial release has the following updates:

Fixed some bugs.

Changes in Issue 04 (2010-09-24)
The fourth commercial release has the following updates:

Fixed some bugs.

Changes in Issue 03 (2010-08-16)
The third commercial release has the following updates:

Fixed some bugs.

Changes in Issue 02 (2010-07-16)
The second commercial release has the following updates:

Fixed some bugs.

Changes in Issue 01 (2010-05-18)
Initial release.
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1 Installation Process

This topic describes the process of installing the U2000 server software.

The SQL Server 2000 database software, U2000 server software, and client software need to be
installed. The following installation schemes are available:
l Preinstallation scheme: The operating system (OS), patches, and U2000 software are

preinstalled on servers delivered by Huawei. Commission the servers directly.
l Installation scheme: If servers are purchased from other suppliers, install the U2000 server

software according to a U2000 deployment plan. For details, see the Software Installation
Guide.

The following figure shows the process of installing U2000 server software according to the
installation scheme.
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Figure 1-1 Process of installing the U2000 server software
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NOTE
Database software will be installed with the U2000 installation. If a database has been installed, verify that
the database meets U2000 installation requirements, and determine whether to reuse the database or install
another database.

The following table shows the chapters for reference and the time required for each installation
stage.
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Table 1-1 Installation process of U2000 according to the installation scheme

Stage Description Reference Duration (Minutes)

1 Prepare for installation. 2 Preparations 40

2 Check installation. 4.2 Pre-installation
Check

20

3 Install an OS and
patches.

If an OS or patch is not
installed, insert a system
software DVD to
complete the installation.

-

4 Install U2000 server
software.

4.3 Starting the U2000
Installation Program

About 120 minutes
(depending on the server
configuration and the
quantity of components
to be installed)

 

iManager U2000 Unified Network Management System
Single-Server System Software Installation Guide
(Windows) 1 Installation Process

Issue 05 (2010-11-19) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

1-3





2 Preparations

About This Chapter

This topic describes the preparations that need to be completed on software, hardware, and
environment before installing U2000 servers.

2.1 Configuration Requirements
This topic describes the configuration requirements on the hardware and software of the server
before installing the U2000.

2.2 Networking Structure
This topic describes the networking structure for a single-server system. Before installing a
Windows single-server system, you must get familiar with the networking structure for the
single-server system.

2.3 Installation Environment Requirements
This topic describes the environment conditions, such as the telecommunications room
environment, cable condition, and networking condition of the telecommunications room, that
you must get familiar with before you install a U2000.

2.4 Collecting Installation Information
This topic describes how to collect installation information. Before installation, collect required
information, including the host name, IP address, time zone and time, user password,
components and instance number, and installation path.

2.5 Checking Required Software
This topic describes the software required to be checked. Ensure that the required software is
on-hand and meets the installation requirements before installing the U2000.

2.6 Checking Hardware Connections
This topic describes how to check that hardware is installed and connected properly.

2.7 Applying for a U2000 License
This topic describes how to apply for a U2000 license.
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2.1 Configuration Requirements
This topic describes the configuration requirements on the hardware and software of the server
before installing the U2000.

Hardware Configuration
The following table shows the configuration requirements on the hardware of the U2000 server.

Table 2-1 Configuration requirements on the hardware for the U2000 server

Server Name Server Description

HP DL380G6 2 x Xeon quadri-core E5504 2.0 GHz or above, 8 GB(4 x 2 GB),
5 x 146 GB(2.5SAS 10K)(RAID10+Hotspare), No FDD, DVD,
4 x Integrated 1000M Multifunc NIC, Integrated P410i(256M)
Raidcard

HP DL580G5 4 x Xeon quadri-core 7430 2.13 GB or above, 16 GB, 4 x 146
GB SFF SAS, No FDD, DVD, 2 x Integrated 1000M NIC,
Integrated P400i ArrayCard

 

Software Configuration
The following table shows the configuration requirements on the software of the U2000 server.

Table 2-2 Configuration requirements on the software for the U2000 server

Configuration Item Typical Configuration

OS Windows Server 2003 R2 Enterprise with SP2
CAUTION

Only a single OS can be installed, and the OS can be installed only on
disk C.

Database MS SQL Server 2000 Standard with SP4 + SQL2000-
KB916287-v8.00.2187

NMS software U2000 software
NOTE

The U2000 software can be installed on the OS with the simplified
Chinese version or English version.

 

2.2 Networking Structure
This topic describes the networking structure for a single-server system. Before installing a
Windows single-server system, you must get familiar with the networking structure for the
single-server system.
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The following figure shows the networking structure for a Windows single-server system.

Figure 2-1 Networking diagram for a Windows single-server system

Server
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Clien
t

DCN

Public network cables
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The U2000 client and U2000 MSuite communicate with the server using a data communication
network (DCN).

NEs and the upper-layer NMS (OSS) communicate with the server using a DCN.

2.3 Installation Environment Requirements
This topic describes the environment conditions, such as the telecommunications room
environment, cable condition, and networking condition of the telecommunications room, that
you must get familiar with before you install a U2000.

Before installing a U2000, check the environment according to the following table.

Table 2-3 Installation environment requirements

Check Item Requirement

Temperature The required temperature range is from 15°C to 30°C in long-term working
conditions and from 0°C to 45°C in short-term working conditions.
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Check Item Requirement

Humidity The required humidity range is from 40% to 65% in long-term working
conditions and from 20% to 90% in short-term working conditions.

Dust The density of the dust whose diameter is larger than 5 μm is less than or equal
to 3×104/m3.

Floor The floor is anti-static movable and must be grounded.

Space The telecommunication room must have good ventilation and enough space
for operation and maintenance.

Power
supply

The power supply should be an independent external power supply system
that can offer stable electricity. The uninterrupted power supply (UPS) is
recommended.

Cable The network where the server is located is normal and can be accessed
successfully.

Network The routers connecting each server are configured. For the installation of
routers, see the installation manual delivered with routers or contact router
suppliers. The networks of routers in every telecommunication room are
connected, including routers and the DCNs.

 

2.4 Collecting Installation Information
This topic describes how to collect installation information. Before installation, collect required
information, including the host name, IP address, time zone and time, user password,
components and instance number, and installation path.

Complete planning for the information listed in the following tables according to the iManager
U2000 Planning Guide. Collect and record the installation information in the tables.

TIP

Print the following tables and fill in the blanks with the site-specific planning information.
Examples provided in the tables are the default values of servers that come pre-installed with software from
Huawei.

Table 2-4 Host name list

Item Example Plan

Server NMSserver  

 

Table 2-5 System IP address list

Item Example Plan

System IP address 129.9.1.1/255.255.255.0/129.9.
1.254
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NOTE

The IP address is in the format of IP address/subnet mask/gateway.

Table 2-6 Time zone and time list

Item Example Plan

Time zone GMT+08:00  

Time 14:00  

 

Table 2-7 User and password list

User Example Plan

OS super user
administrator

admin123  

Database super user
sa

changeme  

Database user
NMSuser

NMSuser  

U2000 user admin admin123  

network management
system maintenance
suite user admin

admin  

 

Table 2-8 Server disk partition list (146 GB disk)

Partition Size (GB) Description

Disk C 40 It is used to install the OS and database software.

Disk D 100 It is used to install the U2000 software and store
the database data.

Disk E Size of the remaining
space

It is used to store the backup data for the
U2000.

 

Table 2-9 Server disk partition list (80 GB disk)

Partition Size (GB) Description

Disk C 80 It is used to install the OS, database and U2000
software.
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NOTE

You must specify the principles and scheme for disk partitioning before installing the U2000 server. For
details about how to set the Windows virtual memory to the system managed size, seeA.1.8 How to Set
the Virtual Memory to the System Managed Size.
The basic principles for disk partitioning are as follows:
l Disk C, as the system disk, is used to install the OS and database software.
l Disk D is used to install the U2000 software and store the database data.
l The remaining space is allocated for free use. It can be used for NMS data backup.

Table 2-10 Installation path list

Software Installation Path

Windows OS C:\

SQL Server database software C:\MSSQL2000

U2000 software D:\U2000

 

NOTE

An installation path name consists of the installation package path name and U2000 installation path name.
It can contain only the letter, digit, and underscore (_). It cannot contain the space or brackets; otherwise,
the installation fails.

Table 2-11 Quantity list of configured components and instances

Example Plan

l One instance for SDH NE
management

l One instance for PTN NE
management

l One instance for router NE
management

l ...

 

 

2.5 Checking Required Software
This topic describes the software required to be checked. Ensure that the required software is
on-hand and meets the installation requirements before installing the U2000.

Installation engineers can install the U2000 in either of the following ways:
l Using software packages: Required software packages must be on-hand.
l Using DVDs: Required DVDs must be on-hand.

Using DVDs
Ensure that the following DVDs are on-hand before installing the U2000 by using DVDs.

2 Preparations
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Table 2-12 DVD list

Software DVD Name

Windows OS software Windows OS installation DVD: Windows Server 2003 R2
Enterprise with SP2
NOTE

There are five Windows OS DVDs available, among which DVDs A, B, and
C are used to install Windows Server 2003 R2 Enterprise with SP1, and
DVDs D and E are used to install Windows Server 2003 R2 Enterprise with
SP2. Only DVDs D and E must be used.

OS patch installation DVD: Windows OS patch:
U2000version_server_ospatch_win32_x86_dvd1

Database software Installation DVD: SQL Server standard edition (installing the
database in the Windows Server 2003 OS):
U2000version_server_dbstd_win32_x86_dvd2

U2000 server software Installation DVD: U2000 software:
U2000version_server_nms_win32_x86_dvd3

 

Using Software Packages
Ensure that the Windows OS installation DVD and software packages are on-hand before
installing the U2000.

Perform the following operations:
TIP

Read the Read Me file before downloading the software packages. The Read Me file is stored in the same
path as software packages.

1. Access http://support.huawei.com and choose Software Center > Version Software >
Network OSS&Service > iManager U2000 > iManager U2000 > iManager U2000 >
iManager U2000 V100R002.

2. Select the version to be installed.
3. Download required software packages listed in Table 2-13. It is recommended that you

use the download tool (for example, Flashget). If you use Windows Internet Explorer, some
software packages may be renamed automatically after being downloaded to the local
computer. In this case, you must manually change the software package names to the same
as those on the http://support.huawei.com.

4. Use the MD5 to verify correctness of the software packages. For details, see A.3.12 How
to Check Downloaded Software Packages by Using MD5 Software.

NOTE

l The Windows OS can be installed only by using DVDs. Therefore, if you install the U2000 by using
software packages, ensure that the Windows OS installation DVD is available.

l In an installation DVD or installation package, Version indicates the detailed version number of the
U2000. For example, V100R002C01SPCxxx.
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Table 2-13 Software package list

Software Medium Name Description

Windows
OS
software

Windows OS installation DVD: Windows
Server 2003 R2 Enterprise with SP2
OS patch installation software package:
Windows OS patch:
U2000version_
server_ospatch_en_win32_x86.zip

It is used to install the
Windows OS. It must be
available.

Database
software

Installation software package: SQL Server
standard edition (installing the database in the
Windows Server 2003 OS):
U2000version_
server_dbstd_en_win32_x86.zip
NOTE

The database software package
U2000version_server_dbper_en_win32_x86.zi
p must be on-hand for installation engineers to
install the U2000 on Windows XP.

It must be available. It is used
to install the database.

U2000
server
software

Basic components:
U2000version_
server_nmsbase_win32_x86.zip

It must be available. It is used
to install the U2000.

Core components:
U2000version_
server_nmscore_win32_x86.zip

It must be available. It is used
to install the U2000.

Transport domain component (optional).
Prepare this component if managing transport
or PTN equipment:
U2000version_
server_nmstrans_win32_x86.zip

It is required only if the
U2000 needs to manage
Huawei transport
equipment. Huawei transport
equipment includes:
l MSTP equipment
l WDM equipment
l NA WDM equipment
l Submarine equipment
l RTN equipment
l PTN equipment
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Software Medium Name Description

IP domain components (optional). Prepare
these components if managing routers,
switches, or security equipment:
U2000version_
server_nmsip_win32_x86.zip

It is required only if the
U2000 needs to manage
Huawei IP equipment.
Huawei IP equipment
includes:
l Routers
l Switches
l Metro service equipment
l Broadband access

equipment
l VoIP gateways
l Firewalls
l Service inspection

gateway
l SVN equipment

Access domain components (optional).
Prepare this component if managing access
equipment:
U2000version_
server_nmsaccess_win32_x86.zip

It is required only if the
U2000 needs to manage
Huawei access equipment.
Huawei access equipment
includes:
l FTTx equipment
l MSAN equipment
l DSLAM equipment

 

2.6 Checking Hardware Connections
This topic describes how to check that hardware is installed and connected properly.

Prerequisite
The server hardware must have been installed and equipment cables must have been connected.

Procedure

1 Ensure that the power cables and ground wires for all components are tightly connected and in
good contact and that the polarities are properly placed.

2 Ensure that all cables are bundled and free of visible damage.

3 Check hardware connections and network cables according to the hardware connection diagram.
l The following figures show hardware connections for the DL380 server.
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Figure 2-2 Hardware connection between the DL380 server

 
l The following figures show hardware connections for the DL580 server.
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Figure 2-3 Hardware connection between the DL580 server

 

4 Check the plugs and sockets.

1. Ensure that the latches of cable plugs are locked fast and the plugs of coaxial cables are
secured tightly.

2. Ensure that the pins in each socket are complete and in good order. Curved pins may cause
short circuits.

5 Ensure that all debris (cable straps, stubs, or moisture-absorbent packets) are picked up.

6 Remove unnecessary items from the telecommunications room. The workbench must be neat
and the movable floor must be level and clean.

----End

2.7 Applying for a U2000 License
This topic describes how to apply for a U2000 license.

Context
l The license file is not delivered to customers along with a U2000 installation DVD. Contact

Huawei engineers to apply for a license according to the contract number and the equipment
serial number (ESN) of the U2000 server.

l An ESN is a string consisting of 40-digit numerals or letters obtained through encrypted
calculation on the MAC addresses of the U2000 server network interface. The number of
ESNs is the same as the number of network interfaces on the U2000 server.
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The U2000 license is valid as long as it is bound to any of the server ESNs. To avoid
applying for a new license due to replacing certain network interface cards (NICs), save
all the ESNs to ensure proper use of the U2000 license.

l A license needs to be bound to an ESN of the server.

Procedure

1 Obtain the contract number.

2 Before installing a U2000, obtain the ESN tool from http://support.huawei.com to generate
ESNs. The ESN tool is named U2000version_ESN_win32_x86.zip.

Decompress the ESN tool package, and then double-click the esn.exe file to view ESNs.

A message similar to the following will be displayed:

ESN0:EBB74B99612CEDC82AD0A59886EC5018CE44DDD4
ESN1:BDA706C825FE0543DC028209778AA66396545412
ESN2:E1B00EEF6947DD95687AA5C608B72ACC532AB2BD
ESN3:F72F9EC08AEE78AA05A42EFD7BFD89F5E03139C4
.....

3 Send the contract number and the ESNs of the server to Huawei engineers or a Huawei local
office.

NOTE

Huawei engineers access the http://license.huawei.com Web site according to the information you provide
to apply for a license file. For details about how to apply for a license file, see the iManager U2000
V100R002C01 License Instructions archived at http://support.huawei.com.

4 Huawei engineers send the license file to you after obtaining it.

The license file delivered along with the U2000 is in .dat format.

----End

2 Preparations
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3 Powering On a Server

This topic describes how to power on a server.

1. Press the power buttons of the peripherals connected to a server and the monitor to power
on the peripherals and monitor.

2. Press the power button on the chassis of the server to power on the server. Take the HP
DL580G5 server as an example. In the following figure, the power button is marked in a
red frame.

Figure 3-1 Position of the power button of the DL580G5 server
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4 Installing the U2000 Server

About This Chapter

This topic describes how to install the U2000 server, involving the U2000 server installation,
installation checks, and installation failure handling.

4.1 Obtaining Installation Software
This topic describes how to obtain installation software. Ensure that the installation DVD or
software package for the U2000 server and database is on-hand.

4.2 Pre-installation Check
This topic describes the checks that need to be performed before you install the U2000 on
Windows OS.

4.3 Starting the U2000 Installation Program
This topic describes how to install U2000 server software.

4.4 (Optional) Loading a U2000 License
This topic describes how to load a U2000 license. If Installation by license is not selected during
installation of the U2000 software, you must upload a U2000 license.

4.5 Verifying the U2000 Server Installation
This topic describes how to verify the U2000 server installation.

4.6 Handling the Failure to Install the U2000 Server Software
This topic describes how to handle the failure to install the U2000 server software.
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4.1 Obtaining Installation Software
This topic describes how to obtain installation software. Ensure that the installation DVD or
software package for the U2000 server and database is on-hand.

Context
The U2000 can be installed by using software packages or installation DVDs. To install the
U2000 by using software packages, perform the following operations to upload software
packages to the server and then decompress them.

Installation DVD
l Windows OS patch: U2000version_server_ospatch_win32_x86_dvd1
l SQL Server standard edition (installing the database in the Windows Server 2003 OS):

U2000version_server_dbstd_win32_x86_dvd2
l U2000 software: U2000version_server_nms_win32_x86_dvd3

Installation Package
To install the U2000 using software packages, visit http://support.huawei.com to download
the required software packages.

Perform the following operations: Visit http://support.huawei.com and choose Software
Center > Version Software > Network OSS&Service > iManager U2000 > iManager
U2000 > iManager U2000 > iManager U2000 V100R002 > iManager U2000
V100R002C01.

l Windows OS patch: U2000version_server_ospatch_en_win32_x86.zip
l SQL Server standard edition (installing the database in the Windows Server 2003 OS):

U2000version_server_dbstd_en_win32_x86.zip

NOTE

The database software package U2000version_server_dbper_en_win32_x86.zip must be on-hand
for installation engineers to install the U2000 on Windows XP.

l Basic components: U2000version_server_nmsbase_win32_x86.zip
l Core components: U2000version_server_nmscore_win32_x86.zip
l Transport domain component (optional). Prepare this component if managing transport or

PTN equipment: U2000version_server_nmstrans_win32_x86.zip
l IP domain components (optional). Prepare these components if managing routers, switches,

or security equipment: U2000version_server_nmsip_win32_x86.zip
l Access domain components (optional). Prepare this component if managing access

equipment: U2000version_server_nmsaccess_win32_x86.zip

4.2 Pre-installation Check
This topic describes the checks that need to be performed before you install the U2000 on
Windows OS.
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Prerequisite

The U2000 server is powered on.

Procedure

1 Perform the following operations to check the OS version and patches:

1. On the desktop, right-click My Computer and choose Properties from the shortcut menu.

2. On the General tab page, verify that the OS version and patches are Windows Server 2003
R2 Enterprise with SP2.

NOTE

If the OS version and patches are incorrect, install a Windows OS with the DVD provided with the server.

2 Check disk partitions. For disk partition requirements, see 2.4 Collecting Installation
Information.

3 Check whether the database has been installed. If the SQL Server database has not been installed,
the server software automatically installs the SQL Server database.

1. Choose start > Programs.

2. Check whether the Microsoft SQL Server program exists. If the program exists, the
database has been installed.

If the SQL Server database has been installed, check whether the database is installed in
binary mode. For details, see A.2.6 How to Check Whether the SQL Server Database
Can Be Sorted in Binary Mode.

If the database is not installed in binary mode, the U2000 fails to install. In this case,
uninstall the database. For details, see A.2.8 How to Manually Uninstall the SQL Server
Database.

3. Ensure that the current database version meets U2000 installation requirements. For details,
see 2.1 Configuration Requirements.

4. Run the following command to check whether the isql command can be executed:
C:\> isql -Usa -Psa password  -Sdatabase name 
1> 

If 1> is displayed, the database can be accessed. Then, run the quit command.

5. Run the following commands to check whether the bcp command can be executed:
C:\> bcp master..sysdatabases out -Usa -Psa password -Sdatabase name -oD:
\test.txt -c

Verify that the test.txt file is generated in disk D and check contents in the file. If replication
data is displayed, the bcp command can be executed.

If the preceding requirements are met, ensure that the database is running. During U2000
installation, a message is displayed asking you whether to reuse the database. In this case, reuse
the database. If the SQL Server database has not been installed, the U2000 server software
automatically installs the SQL Server database.

4 Check whether the current server uses terminal server components.
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CAUTION
If the current server uses terminal server components, the U2000 installation will fail.

1. Open the Control Panel. In Control Panel, double-click Add or Remove Programs.
2. In the Add or Remove Programs dialog box, click Add/Remove Windows

Components in the left pane.
3. In the Windows Components Wizard dialog box, confirm that the Terminal Server check

box is not selected.

----End

4.3 Starting the U2000 Installation Program
This topic describes how to install U2000 server software.

Prerequisite
l The installation software is on-hand. For details about how to obtain the installation

software, see 4.1 Obtaining Installation Software.
l Pre-installation checks have been completed. For details about how to perform pre-

installation checks, see 4.2 Pre-installation Check.
l If a U2000 has been installed before, ensure that the U2000 database file has been deleted

from the current database. For details, see Step 4 in 4.6 Handling the Failure to Install
the U2000 Server Software.

Context
l Ensure that the server system time is correctly set. Stability of the server system time is

critical to the U2000. Do not modify the system time while the system is running.
l In the installation process, the installation program needs to start certain services of a

network adapter. Thus, the network adapter must be connected to the network; otherwise,
the U2000 server cannot be installed.

l After the U2000 has been installed, to prevent the database from being suspended, install
the SQL2000-KB916287-v8.00.2187 patch. For details, see 15.

l If the U2000 software has been installed, the client is also installed on the server.

Procedure

1 Log in to Windows OS as an OS user with administrator rights.

CAUTION
The name of the directory where the installation packages are stored can contain only letters,
digits, and underscores (_). The directory name cannot contain spaces, brackets, or Chinese
characters; otherwise, the installation fails.
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2 Run the install.bat file to start U2000 installation, as follows:

l Mode 1: Installation with a DVD

NOTE
If no database has been installed on the OS, insert a database installation DVD and copy the contents
on the DVD to a path, such as D:\SQLServer, on the local hard disk. During installation, a message
will be displayed prompting you for the path for installing the database.

1. Insert a U2000 installation DVD into the DVD-ROM. Double-click the install.bat file
in the root directory of the installation disk.

2. The dialog box for installing the U2000 MSuite is displayed. Wait 5 to 10 minutes. The
Copyright Notice dialog box will be displayed.

l Mode 2: Installation with a software package:

1. Decompress all installation packages into the same directory. Use the WinRar software
for an example. Select all the packages, right-click , and then choose Extract Here from

the shortcut menu, as shown in .

CAUTION
Do not obtain or decompress client installation packages. Otherwise, a message will be
displayed indicating that the U2000 server software fails to be installed.

If the U2000 is to be installed on Windows XP OS, the database package to be
decompressed is U2000version_server_dbper_en_win32_x86.zip.

There is no requirement on the decompression sequence of software packages. It is
required that the installation software be decompressed to an NT file system (NTFS)
partition. If the corresponding partition does not use the NTFS, convert it to an NTFS
partition before decompressing the installation package. For details, see A.1.2 How to
Convert the File System Type to NTFS.

The installation path, including the installation package path and the U2000 installation
path, can contain only letters, digits, and underscores (_). The installation path cannot
contain spaces or brackets; otherwise, the installation fails.

2. Double-click the install.bat file in the directory of the software package.

3. The dialog box for installing the MSuite is displayed. Wait 5 to 10 minutes. The
Copyright Notice dialog box will be displayed.

NOTE

Read the installation license agreement carefully. If you accept the agreement, click the I accept these
terms option button.

3 Click Accept these terms, and click Next to continue. The Select Language dialog box will be
displayed.

4 Select a language, such as English, and click Next. The Select Scheme dialog will be displayed.

5 Select Single-server system, and click Next. The Select Installation Mode dialog box will be
displayed.
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l Select Installation by typical network. Then, select a scenario from the drop-down list
according to the type of the equipment to be managed.

l Select Installation by license. Then, click Browse to select the license file that has already
been applied for and issued.

l Select Custom installation.
NOTE

Any of the following methods can be used to install the U2000:
l Installation by typical network: Choose the desired scenario according to the type of the equipment

to be managed. The U2000 software provides common scenarios. This method is recommended in
situations where the license file is not on-hand.

l Installation by license: This method is recommended if the license is on-hand.
l Custom installation: This method is applicable to advanced users familiar with managing the network

and U2000. This method is also recommended in the event that the license file is on-hand and the
common scenarios provided by the U2000 software are insufficient.

6 Click Next. The Component dialog box will be displayed.
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l If you select Installation by typical network, the software selects the components to be
installed according to the conditions at your site.

l If you select Installation by license, the software selects the components to be installed
according to the license file.

l If you select Custom installation, the software selects the components to be installed
according to the type of the equipment to be managed.

7 Click Next. The Configure Server dialog box will be displayed.
Set the installation path. For example, d:\U2000.

NOTE

To modify the server, select the server and click Modify. Then, modify server parameters in the dialog box
that is displayed.

If there are multiple IP addresses existing on the server, the system cannot automatically obtain IP addresses.
In this case, modify the server parameters. Specifically, set IP addresses to that for external communication.

The installation path, including the installation package path and the U2000 installation path, can contain
only letters, digits, and underscores (_). The installation path cannot contain spaces or brackets; otherwise,
the installation fails.

8 Click Next. The Deployment Parameters dialog box will be displayed.

NOTE

If the d:\U2000 path does not exist, the Confirm dialog box will be displayed. Click Yes to create the d:
\U2000 path.

l You can modify the number of instances only for components with single-server multi-
instance.

l Limited by the port quantity, a maximum number of 25 instances can be deployed for the
transport domain in the single-server multi-instance deployment mode.

l To use the CORBA northbound interface (NBI), XML NBI, SNMP NBI, and text NBI,
instances must be added by using the Network Management System Maintenance Suite after
installing the desired NBIs.

l If the size of the server memory is 16 GB, set the instance quantity of DeskTop Service
Component to 2.

iManager U2000 Unified Network Management System
Single-Server System Software Installation Guide
(Windows) 4 Installing the U2000 Server

Issue 05 (2010-11-19) Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

4-7



9 Click Next. The Version Style dialog box will be displayed.

NOTE

The following is an example of the differences between the two styles:

l For the default style, alarms are displayed in the following descending order of severity: Critical,
Major, Minor and Warning.

l For the North America style, alarms are displayed in the following five levels in descending order of
severity: Critical, Major, Minor, Not Alarmed and Not Reported.

10 Select a style, such as Default Style, and click Next. The Configure Parameter dialog box will
be displayed.

NOTE

The following provides an example of differences between the two styles:

l For default styles, alarms are generated in the following descending order of severity: Critical,
Major, Minor and Warning.

l For the North America style, alarms are generated in the following descending order of severity:
Critical, Major, Minor, Not Alarmed and Not Reported.

If the components include SDH Network Element Management or SDH Service Management, the
Select Slot Mode dialog box will be displayed. Select a slot mode, such as Interleaving mode. Then, click
Next.
The Sequence mode is the international standard mode and is recommended.

The following table lists parameters for the database U2000 user and the database server.

Parameter Settings

Database Installation Path The default installation path of the database is C:
\MSSQL2000.

Data File Path Specifies the path for storing data files. The default
installation path is C:\data. You are recommended to
click Browse to change the installation path.
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Parameter Settings

DB Super Password Specifies the superuser password of the database. This
password can be left blank (not recommended). The
password must consist of 6 to 30 characters that can be
letters, digits, and underscores (_). For example, it can be
changeme.
CAUTION

If the database has been installed, enter the password for user
sa that is set during database installation.

If you forget the password or the password for user sa does not
meet the requirements, change the password. For details, see A.
2.4 How to Solve the Problem That the Password of User sa
Is Forgotten.

Confirm DB Super Password Confirms the password for user sa. If the database has
been installed, you do not need to enter the password
again.

DB User Password Specifies it to the password of a specific user, with a
minimum of six characters. The default value is
NMSuser.

Confirm DB User Password Confirms the password. The default value is NMSuser.

 

11 Set the installation parameters and click Next. A dialog box will be displayed showing the
installation information.

NOTE

If a message is displayed asking you whether to use the original database software, a database has been installed
on the server. If you decide to reuse the database, the installation program will skip database installation. If you
do not want to reuse the database, you need to manually uninstall the database and then install it.

12 Verify that the installation information is correct and click Next. A progress bar will be displayed.
The time required for the installation depends on the number of components to be installed and
the server configuration. The entire process takes about 120 minutes. Wait patiently.
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NOTE

l The U2000 defines the initial size, increment threshold, increment step length, and auto increment
threshold for the database to be installed. During U2000 installation, the system displays a message
showing the available disk space and the space required for installing a database. If the available
database space is smaller than the increment threshold, auto increment of the database is automatically
triggered. The size of auto increment is determined by the increment step length. When the available
database space reaches the auto increment threshold, auto increment stops.

l The Microsoft Visual C++2005 window is displayed during U2000 installation. Wait about three
minutes. Then the window is automatically closed and no operation is required.

l When the progress bar reaches 99%, the system may wait about half an hour until U2000 installation
is complete. This is normal.

l If an existing database is used, a message is displayed during U2000 installation, indicating that the
current database version is too early. Manually uninstall the database and then reinstall it.

l If a message indicating an installation failure or interruption is displayed during installation, perform
the following operations to clear the installation environment, and then install the U2000.

1. In the Windows Task Manager, click the Processes tab and stop the apache and tomcat processes.

2. Navigate to the C:\HWENGR\engineering\tool path and run the
FailedNMSInstallationClear.bat script to clean up the installation environment.

3. After the installation environment is cleaned up, double-click the install.bat file in the C:
\HWENGR path to start the installation.

13 After the preceding settings, click Finish to complete U2000 installation. The Restart the
operating system dialog box will be displayed.

14 Click No if you do not want to restart the OS immediately.

15 Install the SQL2000-KB916287-v8.00.2187 patch. Double-click SQL2000-KB916287-
v8.00.2187-x86x64-ENU.exe in the Windows OS patch disk or the HWENGR\patch
\sql2000 path of the Windows OS patch installation packages.

NOTE

To prevent the database from being suspended, install the SQL2000-KB916287-v8.00.2187 patch.

16 The installation items in the software update wizard are selected by default. In the
Authentication Mode dialog box, click the Windows Authentication option button. Click
Next to continue until the installation is complete.

17 Restart the OS.

Choose start > Shut Down. The Shut Down Windows dialog box will be displayed. Select
Restart from the What do you want the computer to do drop-down list. Enter information in
the Comment column to make OK available. Then, click OK.

NOTE

After the installation, restart the OS and ensure that the services start successfully.

----End

4.4 (Optional) Loading a U2000 License
This topic describes how to load a U2000 license. If Installation by license is not selected during
installation of the U2000 software, you must upload a U2000 license.
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Prerequisite
l The OS and database must run properly.

If the database has not been started, choose Start > Programs > Microsoft SQL Server
> Service Manager, and then click Start/Continue to start the database.

l The processes of the U2000 must be properly started.
If U2000 services have not been started, run the startnms.bat file in the U2000 installation
path \server\bin to start U2000 services manually.

Context
If you have selected the license installation method during installation, the installation script
automatically copies the license file of a U2000 to the license folder in the U2000 installation
path. Manual operation is not required.

Procedure
l Method one: Use commands to load the license.

1. Copy the authorized license file to the U2000 server. Directly copying and pasting the
license file to the D:\U2000\server\etc\conf\license path is prohibited.

NOTE

l Do not modify the contents in the license file.

l Check whether a temporary license file exists in the D:\U2000\server\etc\conf\license
folder. If the file exists, create a backup folder and then copy and paste the temporary license
file to it.

2. Update the U2000 license.

(1) Log in to the OS of the server.
(2) Run the following command to update the U2000 license file:

> updateLicense -file License_file_name

NOTE

In the command, License_file_name indicates a file name or the combination of an
absolute path and a file name.

Information similar to the following is displayed:
state            product        feature        item        name        
old value        new value
no change:    U2000        COMMON        LSW1CAPA01        Client        
500        500
no change:    U2000        COMMON        LSW1CAPA01        Client        
1        1
no change:    U2000        COMMON        LSW1FMCLT01        Alarm 
Export        1        1
no change:    U2000        COMMON        LSW1RENOTI01        Client        
1        1

Are you sure to update the license?(Y/N)

(3) Enter Y, and then press Enter.

NOTE

After the preceding operations are performed, the license file is automatically loaded to the D:\U2000
\server\etc\conf\license path and renamed.

l Method two: Load the license in the GUI.
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1. Copy and paste the authorized license to the server where the U2000 client is installed.
If the U2000 and server are on the same computer, directly copying and pasting the
license file to the D:\U2000\server\etc\conf\license path is prohibited.

NOTE

l Do not modify the contents in the license file.

l Check whether a temporary license file exists in the D:\U2000\server\etc\conf\license
folder. If the file exists, create a backup folder and then copy and paste the temporary license
file to it.

2. Update the U2000 license.

(1) On the OS desktop, double-click the U2000 Client shortcut icon. The Login
dialog box is displayed.

(2) In the Server drop-down list, select the server to be logged in to. Then, set User
Name and Password to the valid values, and click Login. Click Login. If you
have logged in to the System Monitor before, enter the password for logging in
to the System Monitor. If you have never logged in to the System Monitor before
and this is the first time that you log in to the U2000 client, the password is empty
and you must change the password.

NOTE

l If a message indicating that no license is available when you log in to the U2000
client, select the license to be updated as prompted.

l If Installation by license or an access domain component is selected during
installation, choose Help > License Management  > License Information from the
main menu of the U2000 client.

l In the License Information dialog box, click Update License.

l In the Open dialog box that is displayed, select the new license file and click
Open.

----End

4.5 Verifying the U2000 Server Installation
This topic describes how to verify the U2000 server installation.

4.5.1 Starting a Single-Server System (Windows)
This topic describes how to start a Windows single-server system. After the U2000 server is
started, you must start the U2000. Then, log in to the U2000 to manage networks.

4.5.2 Checking Environment Variables
This topic describes how to check environment variables after the U2000 server software has
been installed.

4.5.3 Checking the U2000 Version
This topic describes how to check the U2000 version.

4.5.1 Starting a Single-Server System (Windows)
This topic describes how to start a Windows single-server system. After the U2000 server is
started, you must start the U2000. Then, log in to the U2000 to manage networks.
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Context
l U2000 services run as background processes. Maintain the U2000 services using a System

Monitor client.
l The client is installed at the same time as the U2000 software. The client described in this

topic is the one installed on the server.
l During installation of the U2000 software, only one default U2000 user, that is, the

admin user, is provided. The admin user is the administrator of a U2000 and has the highest
rights of the U2000.

Procedure

1 Log in to the OS as a user with administrator rights. The system automatically starts the
database and U2000 service.

NOTE

If the database has not been started, choose Start > Programs > Microsoft SQL Server > Service
Manager, and then click Start/Continue to start the database. If the database has been started, the manual
operation is not required.

If U2000 services have not been started, run the startnms.bat file in the U2000 installation path \server
\bin to start U2000 services manually. If the U2000 has been started, the manual operation is not required.

2 Check the shortcut icons.

CAUTION
If you cannot log in to the server through the GUI, skip this step.

The following shortcut icons are displayed on the desktop:

l U2000 Client
l U2000 System Monitor
l U2000 Server
l U2000 NMS Maintenance Suite
l NE Software Management

3 Choose Start > Programs > Network Management System > U2000 System Monitor or
double-click the associated shortcut icon on the desktop to start the System Monitor.

4 In the Login dialog box, enter a user name and password to access the System Monitor window.
The user name is admin and the initial password is blank by default. When you log in to the
System Monitor for the first time, you must change the initial password.

5 Check whether U2000 processes can be properly started. The processes whose startup mode is
manual must be started manually.

6 Start a U2000 client.
1. On the desktop, double-click the U2000 Client shortcut icon.
2. In the dialog box that is displayed, enter a U2000 user name and password. If you have

changed the password for the admin user when logging in to the System Monitor, enter
the new password.
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NOTE

There are two data transmission modes, namely, Common and Security(SSL). You can query data
transmission modes on the server. The default data transmission mode is Common. For details, see
A.3.13 How to Set the Communication Mode on the U2000 server for the Single-Server System
(Windows).

----End

4.5.2 Checking Environment Variables
This topic describes how to check environment variables after the U2000 server software has
been installed.

Procedure

1 Right-click My Computer on the desktop and choose Properties from the shortcut menu.

2 Click the Advanced tab.

3 Click Environment Variables. In the dialog box that is displayed, the environment variables
shown in the following table must exist in the system environment variable area.

Table 4-1 Environment variables used for installing the U2000 server and client

Environment
Variable

Value

IMAP D:\U2000\server\conf

IMAP_CONFIG_
PATH

D:\U2000\server\etc\conf

SSL_CERT_FILE D:\U2000\server\conf\certificate\ca_cert.cer

IMAPROOT D:\U2000

IMAP_ROOT D:\U2000\server

NMSROOT D:\U2000

OSS_ROOT D:\U2000

HWENGRROOT C:\HWENGR

Path d:\U2000\server\3rdTools\lib;d:\U2000\server\3rdTools\python\bin;d:
\U2000\server\3rdTools\python\lib;d:\U2000\server\3rdTools\bin;d:
\U2000\server\bin;d:\U2000\server\lbin;d:\U2000\server\lib;d:\U2000
\server\cbb\frame\lib;d:\U2000\client;C:\HWNMSJRE\jre_win\bin;%
SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32
\Wbem;C:\Program Files\Microsoft SQL Server\80\Tools\BINN;
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NOTE

l Use the installation of a U2000 in the D:\U2000 path as an example. If the U2000 server is installed
in another path, the D:\U2000 path values are different.

l If the actual environment variables are different from the preceding variables, uninstall the U2000 and
then reinstall it.

----End

4.5.3 Checking the U2000 Version
This topic describes how to check the U2000 version.

Procedure

1 Log in to a client.
1. On the desktop, double-click the U2000 client shortcut icon.
2. In the dialog box that is displayed, enter a user name and password.

2 Choose Help > About from the main menu. In the About dialog box, check the U2000 version.

----End

4.6 Handling the Failure to Install the U2000 Server Software
This topic describes how to handle the failure to install the U2000 server software.

Procedure

1 Delete the U2000 database model.

Delete the datamodelDB folder and the files in this folder from the installation software path,
that is, C:\HWENGR\engineering\conf.

2 Restart the database server.

1. Double-click the  icon to the right of the Windows taskbar. The SQL Server Service
Manager dialog box is displayed.

2. Click Stop to stop the database server. Then, click Start/Continue to start the database
server to ensure that the database to be uninstalled is connected properly.

3 Choose Start > All Programs > Administrative Tools > Services. Check whether the
iMapService has been started. If it has been started, stop it. Then, delete the installation path,
such as D:\U2000.

4 Delete U2000 database files.
1. Choose Start > Programs > Microsoft SQL Server > Enterprise Manager. The SQL

Server Enterprise Manager window is displayed.
2. Choose Databases for the local server from the navigation tree. Then, select all the

databases, except master, model, msdb, pubs, tempdb, and Northwind. Right-click the
selected databases and choose Delete from the shortcut menu, as shown in the following
figure.
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NOTE

Backing up important databases in advance. For details about how to back up the databases, see the
iManager U2000 Unified Network Management System Administrator Guide.

3. Choose Security > Login for the local server from the navigation tree. Then, select
NMSuser, right-click, and choose Delete from the shortcut menu.

5 Restart the OS. Log in to the OS as the administrator user. Then, double-click the install.bat
file in the C:\HWENGR path to reinstall U2000 server software.

----End
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A FAQs

This topic provides answers to the most frequent questions concerning the installation.

A.1 Windows OS
This topic provides answers to FAQs about clients installed on Windows OS.

A.2 SQL Server Database
This topic describes the FAQs about the SQL server database.

A.3 U2000 System
This topic covers FAQs about the U2000 system.
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A.1 Windows OS
This topic provides answers to FAQs about clients installed on Windows OS.

A.1.1 How to Add a Static Route

A.1.2 How to Convert the File System Type to NTFS

A.1.3 How to Change the Password of the OS Administrator?

A.1.4 How to Verify That the Video Driver Is Correctly Installed

A.1.5 How to Configure the Remote Login to the Windows OS

A.1.6 How to Forcibly End a Process

A.1.7 How to Configure the FTP, SFTP, or TFTP Service on Windows OS

A.1.8 How to Set the Virtual Memory to the System Managed Size

A.1.1 How to Add a Static Route

Question

If the network connection is unstable, intermittently disconnected, or unreachable, the static
route may be not added. How do I add a static route?

CAUTION
If there are multiple network interfaces and their IP addresses are within different network
segments, the default gateway can be configured on only one of these network interfaces. To
prevent the failure of one network interface from causing the disconnection of the entire network,
the static route needs to be added on other network interfaces.

Answer

1 Run the following command on the command prompt window to view the existing routes:
C:\> route print

2 Run the following command to add a route:
C:\> route -p add network_IP_address mask netmask gateway_IP_address

NOTE

To delete a route, run the following command:

C:\> route delete network_IP_address mask netmask gateway_IP_address

----End
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A.1.2 How to Convert the File System Type to NTFS

Question

How do I convert the file system type to NTFS?

Answer

1 Choose start > Run. The Run window will be displayed.

2 Enter cmd and click OK.

3 Enter convert Drive letter where the installation package is decompressed: /FS:NTFS. For
example, enter convert F: /FS:NTFS if you need to decompress the installation package into
disk F. Enter the corresponding information at the prompt.

4 Restart the OS.

----End

A.1.3 How to Change the Password of the OS Administrator?

Question

How to change the password of the OS administrator?

Answer

1 Log in to the OS as the administrator user.

2 Ensure that the SQL server database is started.

NOTE

If the database is not started, manually start it. Otherwise, login to the database fails after the password is
changed.

If the password of the administrator is changed when the SQL server database is not started, login to the
database fails. In this case, you need to change the password to the original one, start the SQL server
database, and then change the password of the administrator.

3 Press Ctrl+Alt+Delete to lock the current interface.

4 In the dialog box that is displayed, click Change Password.

5 In the dialog box that is displayed, enter the old password and the new password, and confirm
the new password.

6 Click OK.

7 Right-click the database server node of the enterprise manager and choose Properties from the
shortcut menu. In the dialog box that is displayed, click the Security tab, and then change the
administrator password in the Enable Service Account area.

----End
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A.1.4 How to Verify That the Video Driver Is Correctly Installed

Question

How do I verify that the video driver is correctly installed?

Answer

1 Right-click My Computer on the desktop and choose Properties from the shortcut menu.

2 In the System Properties dialog box, click the Hardware tab.

3 On the Hardware tab page, click Device Manager.

In the Device Manager dialog box, expand Display adapters and check whether the video
driver is correctly installed. If a question mask (?) or red cross (X) is displayed, the video driver
is not correctly installed. Check and reinstall the video driver.

----End

A.1.5 How to Configure the Remote Login to the Windows OS

Question

How to configure the remote login to the Windows OS?

Answer

1 Log in to the OS as the administrator.

2 Right-click My Computer and choose Properties from the shortcut menu.

3 In the System Properties dialog box, click the Remote tab.

4 Select the Enable Remote Desktop on this computer check box and click OK.

----End

A.1.6 How to Forcibly End a Process

Question

How do I forcibly end a process?

Answer

1 Press Ctrl+Shift+Esc. The Windows Task Manager dialog box is displayed.

2 Click the Processes tab. Right-click the process needs to be ended, and choose End Process.

----End
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A.1.7 How to Configure the FTP, SFTP, or TFTP Service on
Windows OS

Question
How do I configure the FTP, SFTP, or TFTP service on Windows OS?

NOTE

The third-party tool must be started after the FTP, SFTP, or TFTP server is configured.

Answer
l Configuring the FTP server using the third-party tool wftpd32.exe

1. Copy the wftpd32.exe file to the U2000 server and double-click the file.
2. In the dialog box that is displayed, choose Security > Users/rights and create a user;

choose Security > Host/net and enter the IP address of the FTP server.

l Configuring the SFTP server using the third-party tool msftpsrvr.exe

1. Copy the msftpsrvr.exe file to the U2000 server and double-click the file.
2. In the dialog box that is displayed, create a user.

l Configuring the TFTP server by using the third-party tool tftpd32.exe

1. Copy the tftpd32.exe file to the U2000 server and double-click the file.
2. In the dialog box that is displayed, set the root directory and the IP address of the

TFTP server.
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----End

A.1.8 How to Set the Virtual Memory to the System Managed Size

Question
How to set the virtual memory to the system managed size?

Answer

1 Right-click My Computer and choose Properties from the shortcut menu.

2 In the System Properties dialog box, click the Advanced tab.

3 In the Performance area, click Settings.

4 In the Performance Options dialog box, click the Advanced tab.

5 In the Virtual memory area, click Change.

6 In the Virtual Memory dialog box, click the System managed size option button.

7 Click Set.

8 Click OK.

----End

A.2 SQL Server Database
This topic describes the FAQs about the SQL server database.

A.2.1 How to Check Whether the SQL Server Database Has Been Installed

A.2.2 How to Shut Down the SQL Server Database

A.2.3 How to Start the SQL Server Database

A.2.4 How to Solve the Problem That the Password of User sa Is Forgotten

A.2.5 How to Solve the Problem That the Application Is Suspended During the Installation of
the SQL Server
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A.2.6 How to Check Whether the SQL Server Database Can Be Sorted in Binary Mode

A.2.7 How to Change the Database Sorting Mode to Binary

A.2.8 How to Manually Uninstall the SQL Server Database

A.2.9 How to Check the Name of the SQL Server Database

A.2.1 How to Check Whether the SQL Server Database Has Been
Installed

Question
How do I check whether the SQL Server database has been installed?

Answer
NOTE

l If the SQL Server database has not been installed, when you install the U2000, the SQL Server database
is automatically installed with the U2000.

l If the SQL Server database has been installed, when you install the U2000, a dialog box is displayed
asking you whether to reuse the SQL Server database. If you choose to reuse it, you do not need to
reinstall the SQL Server database and thus can save time; if you choose not to reuse it, you need to
reinstall the SQL Server database. Generally, you are not recommended to reuse the SQL Server
database.

l Consult the computer's administrator to learn whether the SQL Server database has been
installed.

l Check whether the installation directory and file of the SQL Server database exist. A sample
directory is C:\MSSQL2000.

l Manually start the SQL Server database. For details, see A.2.3 How to Start the SQL
Server Database.

l Check whether the database is installed in binary mode. For details, see A.2.6 How to
Check Whether the SQL Server Database Can Be Sorted in Binary Mode.

----End

A.2.2 How to Shut Down the SQL Server Database

Question
How do I shut down the SQL server database?

Answer

1 In the single-server system, choose Start > Programs > Microsoft SQL Server > Service
Manager.
The SQL Server Service Manager dialog box is displayed.

2 Click Stop.

3 Click Yes.

----End
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A.2.3 How to Start the SQL Server Database

Question

How do I start the SQL server database?

Answer

1 In the single-server system, choose Start > Programs > Microsoft SQL Server > Service
Manager.
The SQL Server Service Manager dialog box is displayed.

2 Click Start/Continue.

----End

A.2.4 How to Solve the Problem That the Password of User sa Is
Forgotten

Question

How do I solve the problem that the password of user sa of the SQL server database is forgotten?

NOTE

This method is applicable to scenarios where the NMS is not installed. If the NMS is installed and you
forget the password of user sa, contact Huawei technical support engineers.

Answer

1 Choose start > All Programs > Microsoft SQL Server > Enterprise Manager.

2 In the SQL Server Enterprise Manager window, expand Microsoft SQL Servers > SQL
Server Group in Console Root on the left, and choose Security on a server.

3 Click Login. Double-click the sa item in the right pane, and set the password in the SQL Server
Login Properties-sa dialog box.

----End

A.2.5 How to Solve the Problem That the Application Is Suspended
During the Installation of the SQL Server

Question

How do I solve the problem that the application is suspended during the installation of the SQL
Server?

When the database is not installed for the first time or is reinstalled after the installation failure,
the system displays the message "A previous program installation created pending file operations
on the installation machine. You must restart the computer before running setup."
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Answer
1 Choose Start > Run. The Run dialog box is displayed.

2 Enter regedit and click OK.

3 In the Registry Editor tree, choose My Computer > HKEY_LOCAL_MACHINE >
SYSTEM > CurrentControlSet > Control > Session Manager.

4 In the right pane, right-click PendingFileRenameOperations and choose Delete from the
shortcut menu.

5 Restart the OS.

6 Reinstall the SQL Server database.

----End

A.2.6 How to Check Whether the SQL Server Database Can Be
Sorted in Binary Mode

Question
When you install the SQL Server database, you need to select the binary mode as the sorting
mode. How do I check whether the SQL Server database can be sorted in binary mode?

Answer
1 Run the following commands at the command prompt:

C:\> isql -Usa -Psa password -Sdatabase name
1> sp_helpsort
2> go

If the displayed information includes binary sort, the database is sorted in binary mode. If the
displayed information does not include binary sort, the database is not sorted in binary mode.

----End

A.2.7 How to Change the Database Sorting Mode to Binary

Question
How to change the database sorting mode to binary?

NOTE
This operation is applicable to SQL Server 2000 SP4.

Answer
1 Choose Start > Run. Then, enter cmd to open a CLI.

2 To change the database sorting mode to binary, run the following commands:

C:\> cd C:\HWENGR\engineering\tool\ModifySort

C:\HWENGR\engineering\tool\ModifySort> ModifySort.bat database name sasa
password
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If information similar to the following is displayed, the database sorting mode is changed to
binary.

Starting deal database sort,please wait......
End deal database sort
Starting deal table sort,please wait......
deal DB-Library:'s Tables
All Finish

----End

A.2.8 How to Manually Uninstall the SQL Server Database

Question
How do I manually uninstall the SQL server database?

Answer

1 Ensure that the database is uninstalled correctly by performing the following steps:
1. You need to stop the database server and exit the database service manager before

uninstalling the Microsoft SQL Server 2000.
2. Click Start > Control Panel. The Control Panel window is displayed.
3. Double-click the Add or Remove Programs icon. The Add or Remove Programs

window is displayed.
4. Select Microsoft SQL Server 2000, and then click Change/Remove.

5. Click Yes. A progress bar is displayed.
6. Perform the remaining operations at system prompts.
7. Delete the MSSQL2000 folder in the installation directory of the database.
8. Delete the Microsoft SQL Server folder in the Program files folder that is in the

installation directory of the OS.
9. Delete the MSDesigners7 and MSDesigners98 folders in the Program Files\Common

Files\Microsoft Shared directory that is in the installation directory of the OS.
10. Check whether the following registration table information has been deleted automatically.

If the information exists, manually delete it.

a. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server
b. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSSQLServer
c. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Updates\SQL Server 2000
d. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

\MSSQLSERVER
e. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

\SQLSERVERAGENT
f. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services

\MSSQLServerADHelper

2 After the preceding operations are performed, restart the OS.

3 Ensure that the registries do not contain the PendingFileRenameOperations key value .
1. Click Start > Run. In the Run dialog box, enter regedit to open the registration table.

A FAQs

iManager U2000 Unified Network Management System
Single-Server System Software Installation Guide

(Windows)

A-10 Huawei Proprietary and Confidential
Copyright © Huawei Technologies Co., Ltd.

Issue 05 (2010-11-19)



2. Choose Edit > Find from the main menu. Then, enter PendingFileRenameOperations
and click Find Next.

3. Check that the search result does not include PendingFileRenameOperations. If
PendingFileRenameOperations is included, right-click it and choose Delete from the
shortcut menu.

----End

A.2.9 How to Check the Name of the SQL Server Database

Question
How to check the name of the SQL Server database?

Answer

1 Choose Start > All Programs > Microsoft SQL Server > Client Network Utility. The SQL
Server Client Network Utility dialog box is displayed.

2 Click the Alias tab page to check the database name.

----End

A.3 U2000 System
This topic covers FAQs about the U2000 system.

A.3.1 How to Verify That the U2000 Is Installed

A.3.2 How to Verify That the Processes of the U2000 Single-Server System Are Running on
Windows

A.3.3 How to Start the Processes of the U2000 Single-Server System on Windows

A.3.4 How to End the Processes of the U2000 Single-Server System on Windows

A.3.5 How to Resolve the Problem Wherein the Icon of the U2000 Client Is Inconsistent with
Other Icons

A.3.6 How to Resolve the Problem Wherein the Message "PATH environment's length is too
long" Is Displayed During Installation

A.3.7 How to Determine Which Types of Software Are Preinstalled

A.3.8 Which Installation Packages Are Required for U2000 Installation

A.3.9 How to Process the Message Displayed During Installation of the U2000, Indicating That
a Suspended File Has Been Created

A.3.10 How to Process the Message Displayed During Installation of the U2000, Indicating That
ISQL Connection Check Fails

A.3.11 How to Handle the Problem Wherein the System Displays a Message Indicating That
the Client Installation Packages and Basic Packages Cannot Exist at the Same Time During
Decompression

A.3.12 How to Check Downloaded Software Packages by Using MD5 Software
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A.3.13 How to Set the Communication Mode on the U2000 server for the Single-Server System
(Windows)

A.3.1 How to Verify That the U2000 Is Installed

Question

How do I verify that the U2000 is installed?

Answer
1. Log in to the OS as a user with administrator rights.
2. Check whether the icons of the U2000 client and U2000 System Monitor exist on the

desktop. If they exist, it indicates that the U2000 has been installed.

NOTE

Sometimes, the shortcut icons do not exist on the desktop because they are deleted by mistake. In
this case, check whether the U2000 is installed by choosing Start > All Programs. If the U2000
item exists after you choose Start > All Programs, it indicates that the U2000is installed.

A.3.2 How to Verify That the Processes of the U2000 Single-Server
System Are Running on Windows

Question

How do I verify that the processes of the U2000 single-server system are running on Windows?

Answer

1 Log in to the OS as a user with administrator rights. The system automatically starts the
database and U2000 service.

2 Choose Start > Programs > Network Management System > U2000 System Monitor or
double-click the associated shortcut icon on the desktop to start the System Monitor.

3 In the Login dialog box, enter a user name and password to access the System Monitor window.
The user name is admin and the initial password is blank by default. When you log in to the
System Monitor for the first time, you must change the initial password.

4 Check whether U2000 processes can be properly started. The processes whose startup mode is
manual must be started manually.

----End

A.3.3 How to Start the Processes of the U2000 Single-Server System
on Windows

Question

How do I start the processes of the U2000 single-server system (Windows)?
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Answer

1 Log in to the OS as a user with administrator rights. The system automatically starts the
database and U2000 service.

2 If the database does not automatically start along with the OS, run the following command to
manually start it.

Choose Start > Programs > Microsoft SQL Server > Enterprise Manager, and click Start/
Continue to start the database. If the database has started, skip this step.

3 Manually start the U2000 processes.

You can run the startnms.bat file in the U2000 installation directory \server\bin.

----End

A.3.4 How to End the Processes of the U2000 Single-Server System
on Windows

Question

How do I end the processes of the U2000 single-server system on Windows?

CAUTION
You can stop all the services of the NMS, including the system monitoring process.

If you use the Stop All NMS Services function of the System Monitor, the system monitoring
process is not ended. Do not use this method if perform operations for shutting down the NMS
that are associated with the database.

Answer

1 Exit all the U2000 clients.

2 End the NMS processes.
In the directory of the NMS software after the installation, for example, the D:\U2000\server
\bin directory, run the stopnms.bat file to end the NMS processes.

----End

A.3.5 How to Resolve the Problem Wherein the Icon of the U2000
Client Is Inconsistent with Other Icons

Question

If the U2000 has been reinstalled, the icon of the U2000 client may be inconsistent with other
icons. How do I resolve this problem?
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Answer

1 Right-click on the desktop and choose Properties from the shortcut menu.

2 On the Appearance tab page, click Advanced to access the Advanced Appearance dialog box.

3 Select Icon from the Item drop-down list.

4 Memorize the size of the current default icon. Then, modify the icon size.

5 Click OK twice. The icon size is changed.

6 Repeat the preceding steps to change the icon size back to the default one. The icon is then
normally displayed.

----End

A.3.6 How to Resolve the Problem Wherein the Message "PATH
environment's length is too long" Is Displayed During Installation

Question

When the U2000 is installed on Windows OS, the following message is displayed and the
installation is paused. In this case, how do I resolve the problem?
PATH environment's length is too long. Please delete some useless fields and then 
perform the installation.

Answer

1 Right-click My Computer on the desktop and choose Properties from the shortcut menu.

2 Click the Advanced tab.

3 Click Environment Variables to check whether the environment variable exceeds the
maximum length. When you check the length of the PATH environment variable, you may find
that %PATH% is added to the environment variable. As a result, environment variable exceeds
the maximum length.
... C:\WINDOWS\system32;%PATH%; ...
In this case, delete %PATH% from the environment variable.

----End

A.3.7 How to Determine Which Types of Software Are Preinstalled

Question

Servers come preinstalled with software from Huawei. The U2000 servers come preinstalled to
different extents according to the scheme and software purchased. How do I determine which
types of software are preinstalled?

Answer

In the single-server system: The U2000 is installed based on the bill of material (BOM).
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l If the U2000 license BOM is available, the U2000 needs to be installed according to the
license BOM. Technical support engineers should change the IP address, install the license
on the U2000, and then use the U2000.

l If the U2000 license BOM is unavailable, only the OS needs to be installed.

A.3.8 Which Installation Packages Are Required for U2000
Installation

Question
Which installation packages are required for U2000 installation?

Answer
Prepare installation packages according to the U2000 installation scheme.

Table A-1 DVD list

Software DVD Name

Windows OS software Windows OS installation DVD: Windows Server 2003 R2
Enterprise with SP2
NOTE

There are five Windows OS DVDs available, among which DVDs A, B, and
C are used to install Windows Server 2003 R2 Enterprise with SP1, and
DVDs D and E are used to install Windows Server 2003 R2 Enterprise with
SP2. Only DVDs D and E must be used.

OS patch installation DVD: Windows OS patch:
U2000version_server_ospatch_win32_x86_dvd1

Database software Installation DVD: SQL Server standard edition (installing the
database in the Windows Server 2003 OS):
U2000version_server_dbstd_win32_x86_dvd2

U2000 server software Installation DVD: U2000 software:
U2000version_server_nms_win32_x86_dvd3

 

Table A-2 Software package list

Software Medium Name Description

Windows
OS
software

Windows OS installation DVD: Windows
Server 2003 R2 Enterprise with SP2
OS patch installation software package:
Windows OS patch:
U2000version_
server_ospatch_en_win32_x86.zip

It is used to install the
Windows OS. It must be
available.
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Software Medium Name Description

Database
software

Installation software package: SQL Server
standard edition (installing the database in the
Windows Server 2003 OS):
U2000version_
server_dbstd_en_win32_x86.zip
NOTE

The database software package
U2000version_server_dbper_en_win32_x86.zi
p must be on-hand for installation engineers to
install the U2000 on Windows XP.

It must be available. It is used
to install the database.

U2000
server
software

Basic components:
U2000version_
server_nmsbase_win32_x86.zip

It must be available. It is used
to install the U2000.

Core components:
U2000version_
server_nmscore_win32_x86.zip

It must be available. It is used
to install the U2000.

Transport domain component (optional).
Prepare this component if managing transport
or PTN equipment:
U2000version_
server_nmstrans_win32_x86.zip

It is required only if the
U2000 needs to manage
Huawei transport
equipment. Huawei transport
equipment includes:
l MSTP equipment
l WDM equipment
l NA WDM equipment
l Submarine equipment
l RTN equipment
l PTN equipment

IP domain components (optional). Prepare
these components if managing routers,
switches, or security equipment:
U2000version_
server_nmsip_win32_x86.zip

It is required only if the
U2000 needs to manage
Huawei IP equipment.
Huawei IP equipment
includes:
l Routers
l Switches
l Metro service equipment
l Broadband access

equipment
l VoIP gateways
l Firewalls
l Service inspection

gateway
l SVN equipment
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Software Medium Name Description

Access domain components (optional).
Prepare this component if managing access
equipment:
U2000version_
server_nmsaccess_win32_x86.zip

It is required only if the
U2000 needs to manage
Huawei access equipment.
Huawei access equipment
includes:
l FTTx equipment
l MSAN equipment
l DSLAM equipment

 

A.3.9 How to Process the Message Displayed During Installation of
the U2000, Indicating That a Suspended File Has Been Created

Question
How do I process the message displayed during installation of the U2000, indicating that a
suspended file has been generated?

Answer

1 On Windows OS, the system displays a message indicating that a suspended file is already
created during the reinstallation of the U2000. This is because the suspended file is generated
during the previous installation.

Enter the following command in the address bar and then press Enter:

%tmp%
2 Query the ClearInstallDiskDir.bat file and delete it.

----End

A.3.10 How to Process the Message Displayed During Installation
of the U2000, Indicating That ISQL Connection Check Fails

Question
How do I process the message displayed during installation of the U2000, indicating that ISQL
connection check fails?

Answer

1 Check whether the environment variable path contains the following path and ensure that the
environment variables of other databases are not configured:

C:\Program Files\Microsoft SQL Server\80\Tools\BINN.

2 Choose Start > Program > Microsoft SQL Server > Query Analyzer. On the Connect to
SQL Server page that is displayed, set the IP address of the local host as the service name, select
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the Start SQL Server if it is stopped check box, enter the password of the sa user, and then
click OK. Check whether the SQL Server can be normally connected.

----End

A.3.11 How to Handle the Problem Wherein the System Displays a
Message Indicating That the Client Installation Packages and Basic
Packages Cannot Exist at the Same Time During Decompression

Question

In a scenario where the U2000 server software is installed by using software packages, software
packages are decompressed, the system displays a message indicating that the client installation
packages and basic packages cannot exist at the same time. How do I handle this problem?

Answer

This problem arises because both the server software packages and client software packages are
copied and then decompressed at the same time. To resolve this problem, delete client software
packages and then decompress them again.

A.3.12 How to Check Downloaded Software Packages by Using
MD5 Software

Question

How do I check downloaded software packages by using MD5 software?

Answer

1 Download the MD5_Code_English file from http://support.huawei.com. The
MD5_Code_English file contains MD5 code information after all software and document
packages are decompressed.

NOTE
Perform the following operations to obtain the MD5_Code_English file:

1. Access http://support.huawei.com.

2. Choose Software Center > Version Software > Network OSS&Service > iManager U2000 > iManager
U2000 > iManager U2000 > iManager U2000 V100R002  > iManager U2000 V100R002C01SPC002.

3. Download the MD5_Code_English file in the Release Document column.

2 Navigate to http://www.winmd5.com and download the WinMD5.

3 Double-click WinMD5 1.2.exe to run the WinMD5.

4 Drag the downloaded software package to the window for running the WinMD5. The WinMD5
automatically generates MD5 code information about the downloaded software package and
then compares the information with the counterpart in the MD5_Code_English file.

l The downloaded software package is correct if the information about the software package
is consistent with the counterpart in the MD5_Code_English file.
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l The software package must be re-downloaded if the information about the software package
is inconsistent with the counterpart in the MD5_Code_English file.

----End

A.3.13 How to Set the Communication Mode on the U2000 server
for the Single-Server System (Windows)

Question
The U2000 server and client can communicate with each other in common or Security Socket
Layer (SSL) mode. How to set the common or SSL mode?

Answer

1 Log in to the OS on the U2000 server as an administrator and do as follows to query the
communication mode in use:
Choose Start > Run. In the Run dialog box, enter cmd to open the command line interface
(CLI). Enter ssl_adm -cmd query to query the communication mode that the U2000 server is
using.

2 Stop U2000 processes.
In the U2000 software installation path, for example, D:\U2000\server\bin, run the
stopnms.bat file to stop U2000 processes.

3 Set the communication mode for the U2000 server and client.

Choose Start > Run. In the Run dialog box, enter cmd to open the CLI. Enter ssl_adm -cmd
setmode mode parameter and set the communication mode for the U2000 server and client.

NOTE

The available options for mode parameter are normal, ssl, and both.

l normal: indicates that the U2000 server and client can communicate with each other only in common
mode.

l ssl: indicates that the U2000 server and client can communicate with each other only in SSL mode. In
this mode, communication security is guaranteed between the U2000 server and client.

l both: indicates that the U2000 server and client can communicate with each other in either common
or SSL mode.

4 Start U2000 processes.
In the U2000 software installation path, for example, D:\U2000\server\bin, run the
startnms.bat file to start U2000 processes.

----End
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B Uninstalling the U2000 Server

This topic describes how to uninstall the U2000 server.

B.1 Uninstall Preparations
This topic describes the preparations for uninstalling the U2000 server.

B.2 Uninstall Procedure
This topic describes how to uninstall the U2000 server in a Windows OS.

B.3 Verifying the U2000 Server Uninstall
This topic describes how to verify the U2000 server uninstall.
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B.1 Uninstall Preparations
This topic describes the preparations for uninstalling the U2000 server.

Procedure

1 Log out of all running U2000 clients.

2 Stop U2000 services and processes.
1. Run the stopserver.bat file in the U2000 path, that is, C:\HWENGR\engineering, to end

the U2000 MSuite processes.
2. Run the stopnms.bat file in the U2000 path, for example, D:\U2000\server\bin, to end

U2000 processes.

3 Ensure that U2000 processes have been ended.
1. Press Ctrl+Shift+Esc. The Windows Task Manager dialog box will be displayed.
2. Click the Processes tab. Ensure that the imapmrb.exe, imapwatchdog.exe,

imapsysd.exe, imapeventmgr.exe, imap_sysmonitor.exe, ResourceMonitor.exe,
imapsvcd.exe, EmfGnlDevDm.exe and imapPortTrunkSvc.exe processes have been
ended.

4 In the Windows Task Manager dialog box, click the Processes tab, and end the apache and
tomcat processes.

5 Click Stop and Start/Continue in the SQL Server service manager to restart the SQL Server
database to ensure that no external user accesses the SQL Server database.

NOTE

When uninstalling the U2000 server, ensure that the database works properly. If the database has been
stopped, the uninstall may fail.

----End

B.2 Uninstall Procedure
This topic describes how to uninstall the U2000 server in a Windows OS.

Prerequisite

Preparations for uninstall have been completed.

Context
l Do not uninstall databases when uninstalling the U2000. If the database needs to be

uninstalled, uninstall the U2000 and then the database. Otherwise, some data files cannot
be deleted.

l If the database and backup files need to be saved, manually back up the D:\U2000\server
\var\backup directory to a non-installation directory of the U2000 before uninstalling the
U2000. This directory is generated only after the backup is performed. If no backup has
been performed, this directory does not exist.
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Procedure

1 Log in to a Windows OS as an OS user with administrator rights. Choose start > Programs >
Network Management System > Uninstall U2000.

2 Click Next. The Confirm dialog box will be displayed.

3 Click Yes. The Uninstalling dialog box will be displayed.

4 After the uninstall is complete, the Uninstallation Completed dialog box will be displayed.

5 Click Finish. The Restart the operating system dialog box will be displayed.

6 Click Yes to restart the OS.

7 After the OS is restarted, double-click the stopserver.bat file in the C:\HWENGR
\engineering path to shut down the U2000 MSuite server. Then, delete the C:\HWENGR and
C:\HWNMSJRE paths.

----End

B.3 Verifying the U2000 Server Uninstall
This topic describes how to verify the U2000 server uninstall.

Procedure

1 Ensure that the following shortcut icons are deleted from the Windows desktop: U2000
Client, U2000 Server, U2000 MSuite, NE Software Management, and U2000 System
Monitor. In addition, ensure that the U2000 menu item has been deleted from the Start >
Programs menu.

2 Ensure that the installation path of the U2000 server, such as the D:\U2000 path, is deleted.

3 Ensure that the environment variables of the U2000 have been deleted.
1. Right-click My Computer on the desktop and choose Properties from the shortcut menu.
2. Click the Advanced tab.
3. Click Environment Variables. In the Environment Variables dialog box, verify that

U2000 environment variables have been deleted. For details, see 4.5.2 Checking
Environment Variables.

4 Ensure that U2000 database files have been deleted.
1. Choose start > Programs > Microsoft SQL Server > Enterprise Manager. The SQL

Server Enterprise Manager window will be displayed.
2. Choose Databases for the local server from the navigation tree. Ensure that all databases

have been deleted, except master, model, msdb, pubs, tempdb, and Northwind.

----End
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C Powering Off the System

In any situation, you must follow the correct procedure for powering off the server as required,
ensuring that the server is shut down in a secure manner.

Context

Do not perform this operation when the U2000 is managing NEs normally. You need to shut
down the U2000 only in special cases, such as power supply switching.

Procedure

1 Exit all running U2000 clients.

2 Stop U2000 services and processes.

1. Run the stopserver.bat file in the U2000 path, that is, C:\HWENGR\engineering, to end
the U2000 MSuite processes.

2. Run the stopnms.bat file in the U2000 path, for example, D:\U2000\server\bin, to end
U2000 processes.

3 Stop the SQL Server database service.

1. Choose Start > Programs > Microsoft SQL Server > Service Manager.

2. In the dialog box shown in the following figure, click .
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3. In the dialog box that is displayed, click Yes.

4 Shut down the Windows OS.

----End
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D Acronyms and Abbreviations

A  

ACL access control list

ASCII American standard code for information interchange

  

C  

CD-ROM compact disc-read only memory

CPU central processing unit

  

D  

DC data center

DCN data communication network

DHCP Dynamic Host Configuration Protocol

  

E  

ESN equipment serial number

  

F  

Ftp File Transfer Protocol

  

I  

ID identity

iMAP integrated management application platform

IP Internet Protocol
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IPMP IP network multipathing

  

L  

LCT local craft terminal

LAN local area network

  

M  

MML human-machine language (formerly man-machine language)

MPLS multi-protocol label switching

MA media service access

MAC media access control

MAN metropolitan area network

MAU medium attachment unit

  

N  

NBI northbound interface

NE network element

NIC network information center

NMS network management system

NTP Network Time Protocol

  

O  

OEM original equipment manufacturer

OS operating system

OSS operations support system

  

P  

PC personal computer

PPP Peer-Peer Protocol

PSTN public switched telephone network

PVC permanent virtual circuit
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S  

SCSI small computer systems interface

SDH synchronous digital hierarchy

SNMP Simple Network Management Protocol

SQL structured query language

SSH secure shell

  

T  

Tcp transport control protocol

Tftp trivial file transfer protocol

  

U  

UDP User Datagram Protocol

UPS uninterrupted power supply

  

X  

XML extensible markup language
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