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About This Document 

Purpose 
This document provides the configuration and usage of the unified messaging system (UMS). 

Intended Audience 
This document is intended for: 

 UMS administrators 
 UMS users 

Symbol Conventions 
The symbols that may be found in this document are defined as follows. 

Symbol Description 

Alerts you to a high risk hazard that could, if not avoided, 
result in serious injury or death. 

Alerts you to a medium or low risk hazard that could, if not 
avoided, result in moderate or minor injury. 

Alerts you to a potentially hazardous situation that could, if not 
avoided, result in equipment damage, data loss, performance 
deterioration, or unanticipated results. 

 Provides a tip that may help you solve a problem or save time. 

 Provides additional information to emphasize or supplement 
important points in the main text. 
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Change History 
Updates between document issues are cumulative. Therefore, the latest document issue 
contains all updates made in previous issues. 

Issue 03 (2012-07-10) 
This issue is the third official release, which incorporates the following changes 

 Modified some pictures and the format. 
 Changed the product name SoftCo to Unified Gateway. 

Issue 02 (2012-03-27) 
This issue is the second official release, which incorporates the following changes 

 Added the section about the IVR language setting 
 Modified the information about email parameter setting. 
 Modified some pictures and tables. 

Issue 01 (2010-04-10) 
This issue is the first official release. 
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1 UMS Overview 

1.1 Roles 
The UMS supports the following user roles: 

 Super administrator 
The admin user (super administrator) has all operation rights on the UMS by default, 
and the operation rights can be set. The admin user performs operations such as 
manages rights, sets PBX interaction parameters, sets parameters for SMS notifications 
and emails, monitors system information, and manages system logs. 

 Common administrator 
The operation rights of a common administrator can be set. A common administrator 
performs operations such as manages the UMS user accounts, mailbox, usages, and 
personal greetings. 

 UMS user 
UMS users can obtain messages or faxes, forward messages or faxes, and send faxes. 

 
 A common administrator manages only the user accounts in the local department. 
 The super administrator manages user accounts of all departments. 
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2 Functions for UMS Administrators 

2.1 Logging In to the UMS Web Management System 
You can log in to the UMS web management system in the following way: 

Step 1 Open Internet Explorer, enter the URL of the UMS server, for example, 
http://192.168.1.80:8089, in the address box, and press Enter. 

The login page of the UMS web management system is displayed. 

Step 2 Select Administrator from the Login drop-down list box. Enter the user name and password, 
which are mandatory (the initial account and password are both admin). 

Step 3 Click Login or press Enter directly. 

The Web operation page for the super administrator is displayed, as shown in Figure 2-1. 

Figure 2-1 Web operation page for the UMS super administrator 

 

 

----End 
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2.2 Setup Wizard 
The Setup Wizard is displayed the first time you log in to the UMS web management page, 
and guides you to configure necessary system data, such as license, IVR language, department, 
user account, and unified gateway. 

Step 1 Click Setup Wizard in the navigation tree. 

The Setup Wizard page is displayed, as shown in Figure 2-2. 

Figure 2-2 Setup Wizard 

 

 

Step 2 Click Start Setting. 

Step 3 Select a license, click Upload to upload the license to the UMS server, and click Next, as 
shown in Figure 2-3. 

Figure 2-3 License 

 

 

Step 4 Configure IVR languages and click Next, as shown in Figure 2-4. 
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Figure 2-4 IVR Language 

 

 

Step 5 Configure departments and click Next, as shown in Figure 2-5. 

Figure 2-5 Department 

 

 

Step 6 Configure user accounts and click Next, as shown in Figure 2-6. 

Figure 2-6 User Account 

 

 

Step 7 Configure the Unified Gateway and click Complete, as shown in Figure 2-7. 
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Figure 2-7 Unified Gateway 

 

 

----End 

2.3 System Management 
2.3.1 Unified Gateway 

You must set the interconnection parameters of the UMS server and Unified Gateway on the 
UMS after the UMS parameters are set on the Unified Gateway. The UMS can be 
interconnected with the Unified Gateway successfully only when the interconnection 
parameters are the same as those on the Unified Gateway. 

Choose System Management > Unified Gateway from the navigation tree. The Unified 
Gateway page is displayed, as shown in Figure 2-8. Set the parameters according to Table 
2-1. 
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Figure 2-8 Unified Gateway 

 

 

Table 2-1 Unified Gateway parameters 

Parameter Example Description 

Soft Switch IP 192.168.1.10 IP address of the Unified Gateway, which must 
be the same as that configured on the Unified 
Gateway. 

Soft Switch Port 5060 Port number of the Unified Gateway, which 
must be the same as that configured on the 
Unified Gateway. 

UMS Server IP 192.168.1.80 IP address of the UMS server, which must be the 
same as that configured on the UMS server. 

UMS subnet Mask 255.255.255.
0 

Subnet mask of the UMS server, which must be 
the same as that configured on the UMS server. 

UMS Default Gateway 192.168.44.8
5 

IP address of the default gateway of the UMS 
server, which must the same as that configured 
on the UMS server. 

UMS Unified Access 
Code 

152 Access code of the UMS, which must be the 
same as that configured on the Unified Gateway.
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Parameter Example Description 

Enable MWI Prefix *99* Prefix for turning on the message waiting 
indicator (MWI), which must be the same as that 
configured on the Unified Gateway. 

Disable MWI Prefix *99# Prefix for turning off the MWI, which must be 
the same as that configured on the unified 
gateway. 

Fax Mode T38 Fax 
Mode 

Fax sending and receiving mode, including the 
T38 and G711 fax modes. 

Session Timer Mode Disabled Used to enable or disable the session status 
detection function. 

 

2.3.2 IVR Language 
You can set the IVR languages and corresponding phone keys. 

Step 1 Choose System Management > IVR Language from the navigation tree. The IVR 
Language page is displayed, as shown in Figure 2-9. 

Figure 2-9 IVR Language 

 

 

Step 2 Set the IVR languages and corresponding phone keys. 

NOTE  
 You must set the IVR languages in sequence. You can set the second IVR language only after the 

first IVR language is set, and set the third IVR language only after the first and second IVR 
languages are set. 

 You can delete an IVR language only after subsequent IVR languages are deleted. For example, you 
cannot delete the first IVR language when the second and third IVR languages are not deleted. 

----End 

2.3.3 Email Notification 
The UMS provides a public mailbox(IBM Lotus Notes, Microsoft Exchange, Gmail,etc.) 
receiving voice messages and faxes and sends mails to notify corresponding users. 
You can configure the information such as the server address, port number, 

                                and user of the public mailbox. 
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Choose System Management > Email Notification from the navigation tree. The Email 
Notification page is displayed, as shown in Figure 2-10. Set the parameters according to 
Table 2-2. 

For details on how to configure email servers, see B Appendix: Setting the Gmail Server and 
C Appendix: Setting the Hotmail Server. 

Figure 2-10 Email Notification 

 

 

 

 

Table 2-2 Email notification parameters 

Parameter Example Description 

Server Type POP3 or IMAP Protocol type.  

IMAP Server imap.gmail.com IP address or domain name of the IMAP 
server. 
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Parameter Example Description 

IMAP Port  993 Port number of the IMAP server.  
Generally, the port number is 143. If SSL is 
used, the port number is 993. 

(IMAP)This server 
required an 
encrypted 
connection(SSL): 

Selected or 
deselected 

Select this option based on the port number. 

POP3 Server 192.168.1.6 IP address or domain name of the POP3 
server for receiving emails. 

POP3 Port 110 Port number of the POP3 server for receiving 
emails. Generally, the port number is 110. If 
SSL is used, the port number is 995. 

(POP3)This server 
required an 
encrypted 
connection(SSL): 

Selected or 
deselected 

Select this option based on the port number. 

SMTP Server smtp.gmail.com IP address or domain name of the SMTP 
server for sending emails. 

SMTP Port 465 Port number of the SMTP server for sending 
emails. Generally, the port number is 25. If 
SSL is used, the port number is 465 or 587. 

(SMTP)This server 
required an 
encrypted 
connection(SSL): 

Selected or 
deselected 

Select this option based on the port number. 

SMTP server 
requires 
authentication 

Selected or 
deselected 

Select this option based on the requirements 
of the email service provider. 

User Name zhaotian2472 User name for logging in to the mailbox. 

Password qazwsx User password for logging in to the mailbox.

Email Address zhaotian2472@sohu.
com 

Public email address of the UMS, which is 
used for receiving voice messages and faxes 
and sending them to corresponding users. 
If you use 3.4.1 Sending Messages Using 
Emails or 3.4.2 Sending Faxes Using Emails, 
enter this email address in the recipient 
address box. 

 

2.3.4 Notification Template 
You can configure the contents of SMS, voice mail, and fax notifications. 
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Step 1 Choose System Management > Notification Template from the navigation tree. The 
Notification Template page is displayed, as shown in Figure 2-11. The contents of SMS, 
voice mail, and fax notifications in Chinese, English, and Portuguese are displayed. Figure 
2-11 shows the system initial contents. 

Figure 2-11 Notification Template 

 

 

Step 2 Select a line and click Modify. 

The Modify page is displayed, as shown in Figure 2-12. 

Figure 2-12 Modify 

 

 

Step 3 Set all parameters except Language. 

Table 2-3 Notification template parameters 

Parameter Example Description 

Notification 
content of voice 
mail 

You received a 
new Voice 
Message. 

Subject of the email notification sent when a user 
receives a voice mail. 

Notification 
content of fax 
mail 

You received a 
new Fax 
Message. 

Subject of the email notification sent when a user 
receives a fax mail. 
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Parameter Example Description 

Content of SMS new voice: %1, 
old voice: %2, 
new fax: %3, old 
fax: %4 

Content of an SMS message, where %1, %2, %3, 
and %4 will be replaced with the numbers of new 
voice messages, old voice messages, new faxes, 
and old faxes. 
For example: 
new voice: 2, old voice: 3, new fax: 0, old fax: 2 

 

Step 4 Click Save to save the settings or click the close button to close the page without saving the 
settings. 

----End 

2.3.5 Greeting 
You can query or delete the distinctive greetings of a user on the Greeting page.  

Choose System management > Greeting from the navigation tree. The Greeting page is 
displayed, as shown in Figure 2-13. 

Figure 2-13 Greeting 

 

 

You can perform the following operations: 
 Click Search and enter the user account to query the distinctive greetings of the user. 
 Select one or more records and click Delete to delete the selected records. 
 Click Delete corresponding to a record to delete the record. 

2.3.6 Mailbox 
You can manage the user mailbox to avoid the situation that the user occupies too many 
resources, causing insufficient system resources. 

Choose System Management > Mailbox from the navigation tree. The Mailbox page is 
displayed, as shown in Figure 2-14. 
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Figure 2-14 Mailbox 

 

 

You can perform the following operations: 

 Click Search and enter the phone number to query the messages of the user. 
 Select one or more records and click Delete to delete the selected records. 
 Click Delete by phone number, enter a user account, and click OK to delete the 

information about the user. 
 Click Delete corresponding to a record to delete the record. 

2.3.7 Notification Strategy 
The UMS sends notifications according to the specific number of retry times and retry 
interval in the specific time segment. 

Choose System Management > Notification Strategy from the navigation tree. The 
Notification Strategy page is displayed, as shown in Figure 2-15. 

Figure 2-15 Notification Strategy 

 

 

You can perform the following operations: 

 Click Add to add a notification strategy. 
 Select one or more records and click Delete to delete the selected records. 
 Click Modify corresponding to a record to modify the record. 
 Click Delete corresponding to a record to delete the record. 
 Click Set Default corresponding to a record to set the parameters of the record to the 

default values. When you add an account or add accounts in batches, the default time 
segment set in the notification strategy is used. 
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If a notification strategy is used when you add an account or add accounts in batches, this notification 
strategy cannot be deleted. 

Figure 2-16 shows the page for adding a notification strategy. Set the parameters according to 
Table 2-4. 

For example, if you set the notification strategy for user 8100 according to Table 2-4, the 
UMS periodically checks whether new messages exist in the system according to the preset 
parameter during 08:00-17:00. If yes, the UMS sends a notification message to user 8100. If 
the sending fails, the UMS resends the message for three times at an interval of 60 seconds. 

Figure 2-16 Add Notification Strategy 

 

 

Table 2-4 UMS notification strategy parameters 

Parameter Value Description 

Strategy ID on_work Name of a strategy. 

Invoker 
Identifier 

Enabled The options are as follows: 
 Enabled: The strategy is enabled. When you add an 

account, the strategy time is displayed in the Strategy 
Time drop-down list box. 

 Disabled: The strategy is disabled. When you add an 
account, the strategy time is not displayed in the Strategy 
Time drop-down list box. 

Strategy 
Times 

08:00-17:00 Effective duration for notification modes, such as the MWI, 
phone, SMS message, and email. 
Set Start Time and Over Time and click Add Time to add a 
strategy effective duration. 
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2.3.8 SMS Notification 
The UMS provides the SMS notification function. The UMS sends the messages or faxes to 
the corresponding users in the SMS notification mode. You can set the content template of the 
SMS notification. 

Choose System Management > SMS Notification from the navigation tree. The SMS 
Notification page is displayed, as shown in Figure 2-17. Set the parameters according to 
Table 2-5. 

Figure 2-17 SMS Notification 

 

 

Table 2-5 SMS notification parameters 

Parameter Value Description 

SMS Coding UTF-16BE Select a value from the drop-down list box. The options 
are as follows: 

 GBK 
 UTF-8 
 UTF-16BE 
 UTF-16LE 
 BIG5 

The value is determined by the carrier who provides the 
SIM card of the SMS modem. 

SMS Character 
Set 

UTF-8 Select a value from the drop-down list box. The options 
are as follows: 

 GBK 
 UTF-8 
 UTF-16BE 
 UTF-16LE 
 BIG5 

The value is determined by the UMS server software. 
You are advised to retain the default value. 
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2.3.9 Monitoring 
The UMS scans the latest messages, faxes, and emails periodically. You can configure the 
interval for scanning each item on the Monitoring page. 

Choose System Management> Monitoring from the navigation tree. The Monitoring page 
is displayed, as shown in Figure 2-18. Set the parameters according to Table 2-6. 

 
The value 0 indicates that scanning module is disabled. 

Figure 2-18 Monitoring 

 

 

Table 2-6 Monitoring parameters 

Parameter Value Description 

Phone Notification 
Interval 

10 The system checks the message status at intervals. 
When a new message arrives, the system notifies users 
by phone. The value ranges from 10 to 100000. 

SMS Notification 
Interval 

10 The system checks the message status at intervals. 
When a new message arrives, the system sends SMS 
messages to users by the SMS modem. The value 
ranges from 10 to 100000. 

Email Notification 
Interval 

30 The system checks the message status at intervals. 
When a new message arrives, the system notifies users 
by email. The value ranges from 30 to 100000. 
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Parameter Value Description 

Fax Interval 10 The system checks the fax task at intervals. When a 
new task arrives, the system performs the fax sending 
task. The value ranges from 10 to 100000. 

Message Light 
Interval 

10 The system checks the message status at intervals. 
When a new message arrives, the system sends a 
message to the Unified Gateway for turning on or off 
the MWI. The value ranges from 10 to 100000. 

Remove excess 
Message Cycle 

60 Interval for checking whether the number of messages 
exceeds the maximum. If the number of messages 
exceeds the maximum, the messages are deleted in 
time sequence. The value ranges from 10 to 100000 

Test Email Cycle 0 Interval for checking the system mailbox and obtaining 
voice messages and faxes. The value ranges from 90 to 
100000.  

 

2.4 Account Management 
2.4.1 Department 

A department specifies a set of operation rights of an administrator. You can simplify the 
rights allocation by using the department management function. After the menu rights are set 
for the department, all administrators in this department have the menu rights. 

You can create a department for each department. Administrators of a department can only 
manage UMS user accounts in the department. 

Choose Account Management > Department from the navigation tree. The Department 
page is displayed, as shown in Figure 2-19. 

Figure 2-19 Department 

 

 

You can perform the following operations: 

 Click Search to query the department that meets the requirement after setting the search 
criteria. 

 Click Add to add a department. 
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 Click Modify corresponding to a record to modify the record. 
 Click Delete corresponding to a record to delete the record. 
 Click Configuration menu corresponding to a record to set the user right of this 

department. 

Adding a Department 
Click Add. The page shown in Figure 2-20 is displayed. Set the parameters according to 
Table 2-7. 

Figure 2-20 Add department 

 

 

Table 2-7 Parameters for adding a department 

Parameter Value Description 

Department Department A Department name. 

Browser Menu Display Indicates whether the browser menu is 
displayed. If Hidden is selected, when a user of 
this department logs in to the system, the browse 
menu, including the title, menu bar, and toolbar, 
is not displayed. 

Administrator type General 
Manager 

Type of the administrator, including the common 
administrator and super administrator. For 
details, see 1.1 Roles. 

 

Setting the Department Right 
Click Navigation Bar Configuration corresponding to a record. The page shown in Figure 
2-21 is displayed. 
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Figure 2-21 Department configuration 

 

 

Click the menu item to be added in the navigation tree on the left. The menu item is added to 
the list on the right automatically. Table 2-8 describes the usage of buttons on the page. 

Table 2-8 Usage of buttons on the page 

Button Description 

Remove Remove the selected menu item from the list on the right. 

Clear Clear the list on the right. 

Reset After the rights are allocated but not saved, you can click Reset to restore 
the data. 

Save 
Configuration 

After the rights are allocated, you can click Save Configuration to save 
the configuration. The added menu item can be displayed when an 
administrator of the department logs in to the system. 

Cancel Cancel the right allocation and close the page. 

 

2.4.2 Administrator 
An administrator is a maintenance person in the UMS. The operation rights of the 
administrator depend on those of the home department. The administrator with the department 
maintenance right can assign the rights. 

Choose Account Management > Administrator from the navigation tree. The 
Administrator page is displayed, as shown in Figure 2-22. 
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Figure 2-22 Administrator 

 

 

You can perform the following operations: 

 Click Search to query the administrator that meets the requirement after setting the 
search criteria. 

 Click Add to add an administrator. 
 Click Modify corresponding to a record to modify the record. 
 Click Delete corresponding to a record to delete the record. 

Figure 2-23 shows the page for adding an administrator. 

Figure 2-23 Add Administrator 

 

 

2.4.3 User Account 
You can manage user accounts on the User Account page. 

Choose Account Management > User Account from the navigation tree. The User Account 
page is displayed, as shown in Figure 2-24. 
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Figure 2-24 User Account 

 

 

You can perform the following operations: 

 Click Search and enter the search criteria. The accounts that meet the search criteria are 
displayed in the log list. 

 Click Add to add an account. 
 Click Batch Add to add accounts in batches. 
 Select a record and click Delete to delete the record. 
 Select one or more records and click Batch Delete to delete the selected records. 
 Select a record and click Edit to edit the record. 
 Select one or more records and click Batch Edit to edit the selected records. 

Adding an Account 
Click Add. The page shown in Figure 2-25 is displayed. Set the parameters according to 
Table 2-9. 

 
A common administrator manages only the user accounts in the local department. Therefore, the 
Department parameter is not displayed on the configuration page of the common administrator. 
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Figure 2-25 Add 

 

 

Table 2-9 Parameters for add an account 

Parameter Value Description 

UMS Account 8100 User account for a user to obtain messages after 
logging in to the UMS web management system 
or by phone. You are advised to set it as same as 
the Register Tel. 

Password 123456 Password for a user to obtain messages after 
logging in to the UMS web management system 
or by phone. 

Register No. 8100 Phone number of a user for registration with the 
Unified Gateway. The number must exist on the 
Unified Gateway. 

Fax 78100 Fax number of a user for sending or obtaining a 
fax message. The number must exist on the 
Unified Gateway. 

SMS 13100001234 Mobile number or personal handy-phone system 
(PHS) number for the SMS notifications. 

SMS Marks enable The options are as follows: 
 enable: An SMS message is sent to notify the 

user when a new message or fax is received. 
 disable: No SMS message is sent for 

notification. 

Tel Message 
Light 

8100 Number of the phone where a user MWI is 
located. 
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Parameter Value Description 

MWI Marks enable The options are as follows: 
 enable: The MWI is on when a new message 

or fax is received. After the new message or 
fax is obtained, the MWI is turned off.  

 disable: The MWI does not work. 

Call Back 8100 Phone number set for the voice notifications. 
Note that the voice notifications are sent in the 
time specified in the policy. 

Notice Marks enable The options are as follows:  
 enable: The telephone number specified by 

Notice Phone is dialed when a new message 
or fax is received. The voice "You have X 
new messages" is played when the user picks 
up the phone.  

 disable: No call is made. 

Message 
Duration 

10 Maximum duration of a message, in minutes. 

Language Type English Prompt language when you access the UMS 
voice system. The options are as follows: 

 Chinese 
 English 

Email jaykey@huawei.co
m 

Email address. 

Email Marks enable The options are as follows: 
 enable: An email is sent when a new message 

or fax is received. The attachment is a voice 
or fax file.  

 disable: No email is sent. 

Max Records 10 Total maximum number of messages and faxes 
in the user inbox. If the actual number exceeds 
the value, the system deletes oldest messages. 

Extraction rights Both require a 
password 

The options are as follows: 
 Both require a password: Anyone needs to 

use a password to obtain the message. 
 Receive its owner message: The user can 

only obtain the messages that are sent to the 
personal phone, and the password is not 
required. 

 Receive all user's message: The user can 
obtain the messages of any user from any 
phone and do not need to enter the password. 
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Parameter Value Description 

Strategy Time 08:00-17:00 Time segment for sending the message 
notifications. The value is defined in the 
notification strategy. 

Department Department A Department that the user belongs to, which is 
defined in 2.4.1 Department. Only departments 
of the General Manager type can add accounts. 

DTMF Mode RFC2833/Inband 
Mode 

User signaling between the phone and the switch. 
The options are as follows: 

 RFC2833/Inband Mode 
 Sip Info Mode 

 

Adding Accounts in Batches 
Click Batch Add. The page shown in Figure 2-26 is displayed. Set the parameters according 
to Table 2-9. 

Figure 2-26 Batch Add 
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 A common administrator manages only the user accounts in the local department. Therefore, the 

Department parameter is not displayed on the configuration page of the common administrator. 
 Not all parameters of the account are displayed on the page. The parameters that are not displayed 

are set to the default values. The password must be the same as the account by default. 
 The registration phone number corresponds to the start account. The registration phone numbers of 

other accounts are increased by 1 in sequence. 
 If some of the accounts to be added already exist, the records of the original accounts are not 

replaced when the accounts are added in batches. Only the accounts that do not exist are added. 

2.4.4 User Resource 
You can view the user space usage on the User resource page. If a user occupies excessively 
large space, you can manage the user mailbox in 2.3.6 Mailbox. 

Choose Account Management > User Resource from the navigation tree. The User 
resource page is displayed, as shown in Figure 2-27. 

Enter the user account and select a type. Then click Query to display the file information. 

Figure 2-27 User Resource 

 

 

2.5 System Maintenance 
2.5.1 System Status 

You can view the CPU usage, physical memory, and disk usage of the UMS server on the 
System Status page. 

Choose System Maintenance > System Status from the navigation tree. The System Status 
page is displayed, as shown in Figure 2-28. 
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Figure 2-28 System Status 

 

 

2.5.2 Call History 
You can view the call and fax records of a user. 

Voicemail Records 
Choose System Maintenance > Call History from the navigation tree. The Voice Mail Call 
History page is displayed. 

Click Search. The Search Voice Mail Call page is displayed, as shown in Figure 2-29. Enter 
the search criteria to query the call records.  

Figure 2-29 Search Voice Mail Call 
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Fax Records 
Click the Fax Mail Call History tab and click Search. The Search Fax Mail Call page is 
displayed, as shown in Figure 2-30. Enter the search criteria to query the fax records. 

Figure 2-30 Search Fax Mail Call 

 

 

2.5.3 Logs 
You can view or delete the system logs, download the system logs, or set the storage data and 
level of the logs by using the system log management function.  

Viewing Web Network Logs 
Choose System Maintenance > Logs from the navigation tree. The Web Network Log page 
is displayed, as shown in Figure 2-31.  

Figure 2-31 Web Network Log 
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Enter search criteria. Some of the criteria can be empty, which indicates that the criteria do 
not take effect. 

 Click Search. The found logs are displayed in the log list. 
 Click Clear to clear the search criteria. 

Deleting Logs 
Click Batch Delete in the upper left corner of the page. The page shown in Figure 2-32 is 
displayed. Enter the deleting criteria. Click Clear to clear the search criteria.  

A parameter does not take effect if it is empty. If all criteria are empty, all logs are deleted. 

Figure 2-32 Deleting logs 

 

 

UMS System Logs 
Step 1 Click the UMS System Logs tab. 

The UMS System Logs tab page is displayed, as shown in Figure 2-33. 

Step 2 Set the time for how long logs are saved and the log level (higher log levels cause that more 
logs are saved). You can click Default to restore default settings. 

Step 3 Click Download Log to download log files. 
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Figure 2-33 UMS System Log 

 

 

----End 

2.5.4 License 
You must upload the license file when installing the UMS for the first time. After you upload 
the license file to the UMS server, restart the UMS server. The UMS can be used after the 
UMS server is restarted.  

Step 1 Choose System Maintenance > License from the navigation tree. 

The License page is displayed. 

Step 2 Click Download to save the system information file and send it to Huawei technical engineers 
for applying for a license. 

Step 3 After you apply for the license file, select the ums_license file and click Upload on the 
License page. 

The system displays a message, indicating that the operation is successful. The number of 
concurrent calls and the number of concurrent faxes are displayed on the bottom of the page, 
as shown in Figure 2-34. 
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Figure 2-34 License 

 

 

----End 
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3 Functions for UMS Users 

3.1 Registering and Using the Unified Message Service 
The unified message service allows the UMS to store and manage different messages such as 
voice and fax messages in a unified manner. In this service, users can send and receive 
messages using fixed phones, mobile phones, fax machines, and PCs, anytime and anywhere, 
without switching between these devices. 

 
You must have the unified message service right to register corresponding services. 

3.1.1 CTVMU Service 
If you register the call transfer to voice mailbox unconditional (CTVMU) service, all 
incoming calls are forwarded to the UMS unconditionally. Then the calling party leaves 
messages as prompt by the UMS. 

Registering the Service 
User A picks up the phone and dials *91#. 

User A hears the prompt tone that the CTVMU service is registered successfully. 

Using the Service 
Step 1 User B calls user A and hears the prompt tone and leaves a message as prompted. 

The system notifies user A of the arrival of the new message by sending an email or an SMS 
message or by triggering the message indicator. 

Step 2 User A obtains the message from a phone or mailbox. 

 
User A can obtain messages using any intra-office or outer-office phone. For details, see 3.5.2 Message 
Obtaining Process on the Phone. 

----End 

Precautions 
User B can be an intra-office or outer-office user, but user A must be an intra-office user. 
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The CTVMU service enjoys lower priority than the call forwarding unconditional (CFU) 
service. 

If the phone of user A is a POTS phone connected to the Unified Gateway or a user box, after 
registering the CTVMU service, user A will hear the special dialing tone consisting of beeps 
when user A picks up the phone. 

Canceling the Service 
The CTVMU service can be canceled in the following way: 

User A picks up the phone and dials #91#. 

3.1.2 CTVMNR Service 
If you register the call transfer to voice mailbox on no reply (CTVMNR) service, incoming 
calls are forwarded to the UMS if you do not answer the calls within 20 seconds. Then the 
calling party leaves messages as prompted by the UMS. 

Registering the Service 
User A picks up the phone and dials *93#. 

User A hears the prompt tone that the CTVMNR service is registered successfully. 

Using the Service 
Step 1 User B calls user A, but user A does not answer the call. 

After 20 seconds, user B hears the prompt tone and leaves a message as prompted. 

The system notifies user A of the arrival of the new message by sending an email or an SMS 
message or by triggering the message indicator. 

Step 2 User A obtains the message from a phone or mailbox. 

 
User A can obtain messages using any intra-office or outer-office phone. For details, see 3.5.2 Message 
Obtaining Process on the Phone. 

----End 

Precautions 
User B can be an intra-office or outer-office user, but user A must be an intra-office user. 

The CTVMNR service enjoys lower priority than the CTVMU service, CFU service, and call 
forwarding on no reply (CFNR) service. 

Canceling the Service 
The CTVMNR service can be canceled in the following way: 

User A picks up the phone and dials #93#. 
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3.1.3 CTVMB Service 
If you register the call transfer to voice mailbox on busy (CTVMB) service, incoming calls 
are forwarded to the UMS if the line is busy. Then the calling party leaves messages as 
prompted by the UMS. 

Registering the Service 
User A picks up the phone and dials *92#. 

User A hears the prompt tone that the CTVMB service is registered successfully. 

Using the Service 
Step 1 User B calls user A, but the line is busy. User B hears the prompt tone and leaves a message 

as prompted. 

The system notifies user A of the arrival of the new message by sending an email or an SMS 
message or by triggering the message indicator. 

Step 2 User A obtains the message from a phone or mailbox. 

 
User A can obtain messages using any intra-office or outer-office phone. For details, see 3.5.2 Message 
Obtaining Process on the Phone. 

----End  

Precautions 
User B can be an intra-office or outer-office user, but user A must be an intra-office user. 

The CTVMB service enjoys lower priority than the CTVMU service, CFU service, and call 
forwarding on busy (CFB) service. 

Canceling the Service 
The CTVMNR service can be canceled in the following way: 

User A picks up the phone and dials #92#. 

3.1.4 One-Terminal-One-Number Fax Mailbox Service 
If you register the one-terminal-one-number fax mailbox service, when another user dials 
your fax extension number, the call is forwarded to the UMS. Then the calling party sends fax 
messages as prompted by the UMS. 

Registering the Service 
User A picks up the phone and dials *94#. 

User A hears the prompt tone that the one-terminal-one-number fax mailbox service is 
registered successfully. 
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Using the Service 
Assume that user A has a fax extension number and registers the fax mailbox service. 

Step 1 User B dials the fax extension number of user A. 

The system prompts "Please press the Start button on the fax machine after the beep." 

Step 2 User B presses the Start button. 

The fax machine starts to send fax message. After the sending of fax message is complete, the 
system notifies user A of the arrival of the new fax message by sending an email or an SMS 
message or by triggering the message indicator. 

Step 3 User A obtains the fax message from a fax machine or mailbox. 

 
User A can obtain fax messages using any intra-office or outer-office fax machine. For details, see 3.3.2 
Retrieving Faxes. 

----End 

Precautions 
User B can be an intra-office or outer-office user, but user A must be an intra-office user. 

Canceling the Service 
The fax mailbox service can be canceled in the following way: 

User A picks up the phone and dials #94#. 

3.1.5 Fax Mailbox Service with Unified Access Code 
If you dial the unified access code on a fax machine, the call is forwarded to the UMS. Then 
you send fax message to the called party as prompted. 

Using the Service 
Assume that user A has a fax extension number. 

Step 1 User B dials the unified access code on a fax machine.  

The fax machine prompts "Please enter fax number." 

Step 2 User B dials the fax extension number of user A. 

The fax machine prompts "Please press the Start button on the fax machine after the beep." 

Step 3 User B presses the Start button. 

The fax machine starts to send fax message. The system notifies user A of the arrival of the 
new fax message by sending an email or an SMS message or by triggering the message 
indicator. 

Step 4 User A obtains the fax message from a fax machine or mailbox. 



eSpace UMS 
User Guide 3 Functions for UMS Users

 

Issue 03 (2012-07-10) Huawei Proprietary and Confidential     
Copyright © Huawei Technologies Co., Ltd.

34

 

 
User A can obtain fax messages using any intra-office fax or outer-office fax machine. For details, see 
3.3.2 Retrieving Faxes. 

----End 

Precautions 
User B can be an intra-office or outer-office user, but user A must be an intra-office user. 

3.2 User Operations on the Web Page 
3.2.1 Logging In to the UMS Web Management System 

You can log in to the UMS web management system in the following way: 

Step 1 Open Internet Explorer, enter the URL of the UMS server, for example, 
http://192.168.1.80:8089, in the address box, and press Enter. 

The login page of the UMS web management system is displayed. 

Step 2 Select General User from the Login drop-down list box. Enter the user name and password, 
which are mandatory. 

Step 3 Click Login or press Enter directly. 

The Web operation page for UMS users is displayed, as shown in Figure 3-1. 

Figure 3-1 Web operation page for UMS users 

 

 

----End 

3.2.2 Inbox 
Click Inbox in the navigation tree. The Inbox page is displayed, as shown in Figure 3-1. You 
can perform the following operations: 



eSpace UMS 
User Guide 3 Functions for UMS Users

 

Issue 03 (2012-07-10) Huawei Proprietary and Confidential     
Copyright © Huawei Technologies Co., Ltd.

35

 

Viewing Unread Messages 
You can click New Messages and select Voicemail or Faxmail to view the following 
messages: 

 Unread voice messages 
 Unread fax messages 

Viewing Read Messages 
You can click Old Messages and select Voicemail or Faxmail to view the following 
messages: 

 Read voice messages 
 Read fax messages 

Viewing All Messages 
You can click All Messages to display all messages and faxes. All the information in the 
inbox is displayed no matter whether the information is read. 

Deleting a Record 
Click Delete corresponding to a record to delete the record. 

Deleting Records in Batches 
Select one or more records and click Delete to delete the selected records. 

Downloading Files 
Click Download corresponding to a record to download the record. 

If a page is displayed, indicating that the download is rejected, right-click and choose 
Download, and then click Download corresponding to the record. 

Forwarding Faxes 
Click Forward corresponding to a fax record. The page shown in Figure 3-2 is displayed. 
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Figure 3-2 Forward 

 

 

 Sending an internal fax 
Send a fax to the inbox of a UMS user. Click the Internal fax option button. The users 
who have faxes are displayed in the list on the right.  
Click a user account. The selected user is automatically added in the User account list 
box. Alternatively, you can enter the user accounts (separated by a semicolon) in the 
User account list box, and then click Send. 

 Sending an external fax 
Send a fax to the inbox of either an internal or external user. Click the External fax 
option button. The users who have faxes are displayed in the list on the right.  
Click a user account. The selected user is automatically added in the Fax number list 
box. Alternatively, you can enter the fax numbers (separated by a semicolon) in the Fax 
number list box, and then click Send. 

 
If an entered user account does not exist, a message is displayed, indicating that the sending fails. The 
other accounts, however, are not affected. 

Forwarding Voice Messages 
Click Forward corresponding to a voice record. The page shown in Figure 3-3 is displayed. 
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Figure 3-3 Forward 

 

 

 Sending an Internal Message 
Send an internal message to the inbox of a UMS user. Click the Send internal message 
option button. The users whose numbers are registered with the UMS are displayed in 
the list on the right.  
Click a user account. The selected user is automatically added in the User account list 
box. Alternatively, you can enter the user accounts (separated by a semicolon) in the 
User account list box, and then click Send. 

3.2.3 Sending Faxes 

Figure 3-4 Send Fax 
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Sending an Internal Fax 
To send a fax to the inbox of a UMS user, perform the following steps: 

Step 1 Click the Internal fax option button. 

The users who have faxes are displayed in the list on the right. 

Step 2 Use either of the following methods to add a user account: 

 Click a user account. The selected user is automatically added in the User account list 
box. 

 Enter the user accounts (separated by a semicolon) in the User account list box 

Step 3 Enter the subject and select an attachment. 

Step 4 Click Send. 

 
If an entered user account does not exist, a message is displayed, indicating that the sending fails. The 
other accounts, however, are not affected. 

----End 

Sending an External Fax 
To send a fax to the inbox of either an internal or external user, perform the following steps: 

Step 1 Click the External fax option button. 

The users who have faxes are displayed in the list on the right. 

Step 2 Use either of the following methods to add a user fax number: 

 Click a user account. The selected user is automatically added in the Fax number list 
box. 

 Enter the fax numbers (separated by a semicolon) in the Fax number list box. 

Step 3 Enter the subject and select an attachment. 

Step 4 Click Send. 

\ 
If an entered user account does not exist, a message is displayed, indicating that the sending fails. The 
other accounts, however, are not affected. 

----End 

3.2.4 Outbox 
Click Outbox in the navigation tree. The Outbox page is displayed, as shown in Figure 3-5. 
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Figure 3-5 Outbox 

 

 

You can query the information about all sent faxes, including the fax content, time, phone 
number, and failure reason, and perform the following operations: 

 Click Sending to view the messages that are being sent. 
 Click Send Successfully to view the messages that are sent. 
 Click Send Failed to view the messages that fail to be sent. 
 Click All to view all the messages that are sent or being sent. 
 Click Delete to delete the messages. 
 Click Download to download the messages. 

3.2.5 Address Book 
The address book is used to manage the contacts of the user, including recording the phone 
numbers and fax numbers of the contacts. 

Click Address Book in the navigation tree. The Address Book page is displayed, as shown in 
Figure 3-6. 

Figure 3-6 Address Book 

 

 

You can perform the following operations: 

 Click Add contact to add a contact. 
 Click Modify corresponding to a record to modify the record. 
 Click Delete corresponding to a record to delete the record. 
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Figure 3-7 shows the page for adding a contact. 

The parameter with a red asterisk (*) is mandatory. You can simply select a contact when 
sending a message or fax subsequently. The corresponding phone number and fax number are 
entered automatically. 

Figure 3-7 Add Contact 

 

 

3.2.6 Personal Setting 
Click Personal Setting in the navigation tree. The Personal Setting page displayed, as shown 
in Figure 3-8. 

Figure 3-8 Personal Setting 
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You can modify the personal information. The parameter with a red asterisk (*) is mandatory. 
Table 3-1 describes the parameters. When any parameter is modified but not saved, click 
Reset to restore the settings. 

Table 3-1 Personal information parameters 

Parameter Value Description 

User Account 8100 User account for a user to obtain messages after 
logging in to the UMS web management system 
or by phone. 

Register No. 8100 Phone number of a user for registration with the 
Unified Gateway. 

Password - Password for a user to obtain messages after 
logging in to the UMS web management system 
or by phone. You do not need to set the 
parameter if the password is not changed. 

Max Records 10 Total maximum number of messages and faxes 
in the user inbox. If the actual number exceeds 
the value, the system deletes oldest messages. 

Confirm 
Password 

- Password that a user enters to confirm the login 
password. 

Notice Tel 8100 Phone number set for the voice notifications. 
Note that the voice notifications are sent in the 
time specified in the policy. 

Tel Message 
Light 

8100 Number of the phone where a user MWI is 
located. 

Fax Tel 8100 Fax number of a user for sending or obtaining a 
fax message. 

SMS Tel 13100001234 Mobile number or PHS number for the SMS 
notifications. 

Language Types English The UMS supports Chinese and English. 

Email 8110@huawei.com Email address for sending and receiving 
messages or faxes. This parameter is mandatory 
if you need to use the email address to send 
messages or faxes. 

Strategy Time 17:30-24:00 Time segment for sending the message 
notifications. The value is defined in the 
notification strategy. 
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3.3 User Fax Operations 
3.3.1 Sending Faxes 

Sending Faxes In the UMS Web Management System 
For details on how a UMS user sends faxes in the UMS web management system, see 3.2.3 
Sending Faxes. 

Sending Faxes Using Emails 
For details on how a UMS user sends faxes using emails, see 3.4.2 Sending Faxes Using 
Emails. 

3.3.2 Retrieving Faxes 
Faxes can be retrieved in the following ways: 

 Using the fax machine 
You can dial the system access code and enters the specified fax number to retrieve faxes 
as prompted. For details, see 3.5.2 Message Obtaining Process on the Phone. 

 Using the phone 
You can dial the system access code and retrieve faxes as prompted. For details, see 3.5.2 
Message Obtaining Process on the Phone. 

 Using the web management system. 
You can log in to the UMS web management system, and retrieve fax files from the 
inbox. 

 Using emails 
If email notification is enabled, when the UMS receives a fax, it sends the fax to the 
specified mailbox. The fax content is saved in the attachment. You can log in to the 
mailbox to retrieve the fax. 

3.4 User Email Operations 
3.4.1 Sending Messages Using Emails 

This type of emails can be sent only to the intra-office UMS users. To send a message using 
emails, perform the following steps: 

Step 1 Set an available email address in 3.2.6 Personal Setting. 

Step 2 Create an email. 

1. Enter the public email address provided by the UMS server in the recipient address box. 
2. Enter the UMS accounts, each separated with a semicolon (;), in the subject text box. 
3. Attach a .wav file. 

Step 3 Send the email. 

----End 
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3.4.2 Sending Faxes Using Emails 
This type of emails can be sent to both intra-office and outer-office UMS users. To send a fax 
using emails, perform the following steps: 

Step 1 Set an available email address in 3.2.6 Personal Setting. 

Step 2 Edit an email. 

1. Enter the public email address provided by the UMS server in the recipient address box. 
2. Enter the subject: 

− If the fax is sent to a fax machine, enter the number sign (#) and the fax number of 
the recipient in the subject text box. If multiple fax numbers are entered, separate 
each with a semicolon (;). A fax number can be either an inter-office or outer-office 
number. 

− If the fax is sent to the inbox of the UMS web management system, enter the UMS 
accounts, each separated with a semicolon (;) in the subject text box. 

3. Attach a .tif file. For details on how to convert a .doc file to a .tif file, see A Appendix: 
Converting .doc Files to .tif Files. 

Step 3 Send the email. 

----End 

3.5 User Operations on the Phone 
3.5.1 Message Leaving Process on the Phone 

Based on the system configuration, the calling party can be forwarded to the message leaving 
system of the called party unconditionally, on no reply, or on busy. Figure 3-9 shows the 
operation process. 
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Figure 3-9 Message leaving process on the phone 
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3.5.2 Message Obtaining Process on the Phone 
After dialing the number for obtaining a message, you must enter the account and password as 
required, and access the message obtaining process. Figure 3-10 shows the operation process. 
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Figure 3-10 Message obtaining process on the phone 
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A Appendix: Converting .doc Files to .tif 
Files 

When sending faxes in the UMS web management system or using emails, you must select 
the faxes in .tif format. If the file is in .doc or .xls format, you can install a third-party virtual 
print program, such as the SmartPrinter and Microsoft Office Document Image Writer, to 
convert formats. 

For example, to convert a .doc or .xls file to a .tif file by using the Microsoft Office Document 
Image Writer, perform the following steps: 

Step 2 Install the Microsoft Office Document Image Writer. 

Select Microsoft Office Document Image Writer when installing the Microsoft Office. 

If Microsoft Office is already installed, choose Start > Programs > Microsoft Office > 
Microsoft Office Tools > Microsoft Office Document Imaging to install Microsoft Office 
Document Image Writer. 

Open the .doc or .xls file, and then choose File > Print. Select Microsoft Office Document 
Image Writer from the Name drop-down box, as shown in Figure A-1. 

Figure A-1 Print options 
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Step 3 Click Properties and click the Advanced tab in the displayed dialog box, as shown in Figure 
A-2. 

Figure A-2 Print properties 

 

 

Step 4 Select TIFF-Monochrome Fax in the Output format area, and click OK. 
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Step 5 Click OK. A dialog box is displayed for you to select a file path. 

Step 6 Select a file path, and click Save to start converting the file. After the conversion is complete, 
the converted file is placed in the selected path. 

----End 
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B Appendix: Setting the Gmail Server 

B.1  Setting Gmail Account Parameters 
B.1.1  Setting Gmail Display Language 

Step 1 Log in to the Gmail in a browser, choose Settings > General, and set Gmail display 
language to English (US), as shown in Figure B-1. 

Figure B-1 Setting Gmail display language 

 

 

Step 2 Save the settings. 

----End 

B.1.2  Enabling IMAP 
You must enable IMAP so that you can access the Gmail from other clients. 

Step 1 Log in to the Gmail in a browser, choose Settings > Forwarding and POP/IMAP, and select 
Enable IMAP, as shown in Figure B-2. 

Figure B-2 Enabling IMAP 
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Step 2 Save the settings. 

----End 

B.2  Setting UMS Email Parameters 
B.2.1  Setting Parameters for Receiving Emails 

Step 1 Log in to the UMS as the system administrator in a browser, and choose UMS > Email 
Notification. 

The Email Notification page is displayed, as shown in Figure B-3. 

Step 2 Set Server Type to IMAP. 

Step 3 Set IMAP Server to imap.gmail.com. 

Step 4 Set IMAP Port to 993. 

Step 5 Select (IMAP)This server requires an encrypted connection(SSL). 

Figure B-3 Setting parameters for receiving emails 
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----End 

B.2.2  Setting Parameters for Sending Emails 
Step 1 Set SMTP Server to smtp.gmail.com, as shown in Figure B-4. 

Step 2 Set SMTP Port to 465. 

Step 3 Select (SMTP)This server requires an encrypted connection(SSL). 

Step 4 Select SMTP server requires authentication. 

Figure B-4 Setting parameters for sending emails 

 

 

----End 

B.2.3  Setting the UMS Public Mailbox 
Step 1 Set User Name to umstest01, as shown in Figure B-5. 

Step 2 Set Password to umspwd01. 

Step 3 Set Email Address to umstest01@gmail.com. 

Figure B-5 Setting the UMS public mailbox 

 

 

Step 4 Save the settings. 

----End 
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B.3  Setting the Intervals for Receiving and Sending 
Emails 
B.3.1  Setting the Interval for Receiving Emails 

Step 1 Log in to the UMS as the system administrator in a browser, and choose System 
Management > Monitoring. 

Step 2 Set Test Email Cycle to 300, as shown in Figure B-6. 

Figure B-6 Setting the interval for receiving emails 

 

 

----End 

B.3.2  Setting the Interval for Sending Emails 
Step 1 Log in to the UMS as the system administrator in a browser, and choose System 

Management > Monitoring. 

Step 2 Set Email Notification Interval to 30, as shown in Figure B-7. 

Figure B-7 Setting the interval for sending emails 

 

 

Step 3 Save the settings. 

----End 



eSpace UMS 
User Guide A Appendix: Converting .doc Files to .tif Files

 

Issue 03 (2012-07-10) Huawei Proprietary and Confidential     
Copyright © Huawei Technologies Co., Ltd.

53

 

C Appendix: Setting the Hotmail Server 

C.1  Setting Hotmail Account Parameters 
C.1.1  Enabling POP3 

Step 4 Log in to the Hotmail in a browser, and choose Hotmail Options > Options > POP and 
deleting downloaded messages, as shown in  

Step 5 Select Do what my other program says-if it says to delete messages, then delete them. 

Step 6 Click Save. 

Figure C-1 Enabling POP3 

 

 

----End 

C.2  Setting UMS Email Parameters 
C.2.1  Setting Parameters for Receiving Emails 

Step 1 Log in to the UMS as the system administrator in a browser, and choose UMS > Email 
Notification. 

The Email Notification page is displayed, as shown in Figure C-2. 

Step 2 Set Server Type to POP3. 
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Step 3 Set POP3 Server to pop3.live.com. 

Step 4 Set POP3 Port to 995. 

Step 5 Select (POP3)This server requires an encrypted connection(SSL). 

Figure C-2 Setting parameter for receiving emails 

 

 

----End 

C.2.2  Setting Parameters for Sending Emails 
Step 1 Set SMTP Server to smtp.live.com, as shown in Figure C-3. 

Step 2 Set SMTP Port to 587. 

Step 3 Select (SMTP)This server requires an encrypted connection(SSL). 

Step 4 Select SMTP server requires authentication. 

Figure C-3 Setting parameters for sending emails 

 

 

----End 

C.2.3  Setting the UMS Public Mailbox 
Step 1 Set User Name to umstest01, as shown in Figure C-4. 

Step 2 Set Password to umspwd01. 

Step 3 Set Email Address to umstest01@hotmail.com. 
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Figure C-4 Setting the UMS public mailbox 

 

 

Step 4 Save the settings. 

----End 

C.3  Setting the Intervals for Receiving and Sending 
Emails 
C.3.1  Setting the Interval for Receiving Emails 

Step 1 Log in to the UMS as the system administrator in a browser, and choose System 
Management > Monitoring 

Step 2 Set Test Email Cycle to 900, as shown in Figure C-5. 

Figure C-5 Setting the interval for receiving emails 

 

 

----End 

C.3.2  Setting the Interval for Sending Emails 
Step 1 Log in to the UMS as the system administrator in a browser, and choose System 

Management > Monitoring. 

Step 2 Set Email Notification Interval to 30, as shown in Figure C-6. 

Figure C-6 Setting the interval for sending emails 

 

 

Step 3 Save the settings. 

----End 
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